Take the 2-minute tour ×
Windows Phone Stack Exchange is a question and answer site for enthusiasts and power users of Windows Phone OS. It's 100% free, no registration required.

So I got a new Lumia 920 but I can get gmail to work properly. I set it up using the "gmail" option when you create an account. I set to download items as they arrive.

But when I get an email from gmail, the phone doesn't seem to realize, I can only see the email if I open the gmail account. However, my iPhone does receive the email from gmail instantly.

Another thing that happens is that when I read an email in the gmail account in the phone, it won't show as "read" in my laptop's gmail page in the browser. Not even if I refresh the inbox.

In my iPhone it all works perfectly, I get the notifications instantly and it's all perfectly synchronized.

Am I missing something?

share|improve this question
    
Go into your settings and open Email and Accounts section again. If there is a problem with the syncing, you will see a status underneath the account name. Is there a notification there? –  Lance McCarthy Nov 12 '12 at 23:11
    
no there isn't, it looks like it's set up properly, it just that emails don't get to the phone if I don't manually sync –  Albert Nov 13 '12 at 0:14
    
For notification problem, how many other email accounts do you have setup? Could it be related to this windowsphone.stackexchange.com/questions/519/… ? –  row1 Dec 2 '12 at 15:17
    
I retuned my lumia (not for this reason) and got a galaxy note 2. Best decision ever! It's an amazing phone :) –  Albert Dec 2 '12 at 20:27

1 Answer 1

This might the solution you are looking for: http://www.neowin.net/news/how-to-use-google-services-in-windows-phone-8

Check the section Push Gmail and syncing contacts:

While there is an easy option to simply sync your account as a Google account in the settings, you'll get better results if you set it up as an Exchange ActiveSync account because it enables push email. Don't worry, because all of your contacts and your primary calendar will be synced across as well, just like if you were to set it up as a standard Google account.

. . .

To set up said Exchange ActiveSync account, go to the phone settings and then to email+accounts > add an account > Advanced Setup. In this menu, enter your Google account's email address and password, click next and then choose Exchange ActiveSync. From this menu with more options, the necessary Server box appears; here enter m.google.com, click sign in and you're all good to go (leave the Domain box blank).

Screenshots and more details at the linked article.

share|improve this answer
2  
While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. –  Matthew Dec 11 '12 at 22:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.