Take the 2-minute tour ×
Windows Phone Stack Exchange is a question and answer site for enthusiasts and power users of Windows Phone OS. It's 100% free, no registration required.

I have problem with my spreadsheet which is located on Skydrive. It's readonly in my phone.

It started after I updated my phone from 7.5 to 7.8. If I create a new document on my phone, I can edit it without any problems, but when I edit it from skydrive, it starts be readonly on my phone.

I have searched throught the skydrive options but I couldn't find a solution. Has somebody encountered have this problem before? How can I fix it?

share|improve this question
I have the same problem. As soon as Windowa Phone 7.5 upgraded to 7.8 all documents created on my WP7.5 would not open. Same goes for Word and PowerPoint docs. –  user1425 May 27 '13 at 11:47

1 Answer 1

It sounds like you're trying to edit a non-Office Open XML document. If this is the case, you'll need to upgrade the document to the Office 2007+ format.

share|improve this answer
Ok, is there a setting which set it? How can I change it for my whole skydrive? –  Mateusz Rogulski Feb 9 '13 at 9:36
I mean it sounds like the spreadsheet was created with Excel 2003 or earlier. You can only edit Office 2007 or later documents on Windows Phone. Here is a SuperUser question asking how to convert old documents to the new format. If one of these answers works for you, you could do it on your SkyDrive folder. –  Louis Feb 9 '13 at 9:42
Unfortunately, WP and Skydrive doesn't create spreadsheet in Excel 2003 format. –  Mateusz Rogulski Feb 9 '13 at 9:59
@MateuszRogulski are you files .xls or .xlsx? –  Louis Feb 9 '13 at 11:13
It is .xlsx format. –  Mateusz Rogulski Feb 9 '13 at 11:35

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.