Take the 2-minute tour ×
Windows Phone Stack Exchange is a question and answer site for enthusiasts and power users of Windows Phone OS. It's 100% free, no registration required.

I currently have my google account hooked up to my windows phone 7.5 (mango) device and it works fine, syncing my email, calendar, and contacts.

However, it only seems to sync my main calendar, not any shared calendars. Is there a way I can get my shared calendars down to my windows phone?

Thanks!

share|improve this question
add comment

4 Answers

up vote 10 down vote accepted

Microsoft has a knowledge base article out for this.

  1. From the Start screen on your Windows Phone, flick left to the App list, and then tap Internet Explorer.
  2. Tap elipsis , located at the bottom of the screen, and then tap Settings.
  3. Locate Website preference, and tap Mobile version from the drop-down list. Press the back button on your phone to return to Internet Explorer.
  4. Tap the address bar, and enter http://m.google.com/sync. If this is your first time visiting, tap Sign in with your Google Account.
  5. As soon as you're signed in, select your phone from the device list. Note if you have multiple devices and don't know which one to select, yours should be listed as WindowsPhone and have a "Last sync" date value that is recent.
  6. Under the headings My Calendars and Shared Calendars, tap the check box next to each calendar that you want to sync with your phone. Tap Save. Note the additional calendars selected will show up after your phone's next sync with Google (every 30 minutes by default).
  7. Start a manual sync with Google to see your new calendars by going to the Start screen on your Windows Phone. Flick left to the App list, and then tap Settings. Tap Email+accounts. Tap and hold the Google account, and tap Sync.
  8. To see your new Google calendars, go to Calendar on your phone. You should now see appointments for your secondary Google calendars. If you want to configure what calendars display, tap , and then tap Settings. Note All Google calendars selected in step 6 should now show up and be turned on.
share|improve this answer
1  
This method no longer works. See the new one. –  Vitor Canova Feb 2 '13 at 11:29
    
This method still works just fine if you use the WP app "User Agent Switcher", elipsis->iphone, and continue on from step 4 –  pyInTheSky Feb 7 '13 at 20:25
add comment

Looks like the answer is no longer "the answer" since this method is not possible. But I found a solution.

  1. Add Google account in you phone and make sure that you main calendar appeared in the app.
  2. Go to you Computer to the next steps.
  3. Close all browser tabs you have.
  4. Disable javascript.*
  5. Change the User Agent to iPad.**
  6. Make sure above steps works***
  7. Navigate to Google.com and do you login. (Actually you can do this step first but I did at this point)
  8. Navigate to https://m.google.com/sync/settings/ . I think this step only works if you browser is set to English.****
  9. At this point you can see a list with your apps. Find Windows Phone and it will show all your calendars. Check every calendar you want and save. After that sync you phone again.

*In IE9+ go to Settings->Internet Options->Security->Custom Level->Scripting->Active Scripting->Disabled

**IE9: Open developer tools (F12)->Tools->Change user agent string->Custom-> Create a new one with:

Mozilla/5.0 (iPad; CPU OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3

**IE10: Open developer tools (F12)->Tools->Change user agent string->Apple Safari(iPad)

***Go to Google.com and search for something without hit ENTER. If javascript is really disable instant search will not work. Search for "whats my user agent" and you need to see this:

Mozilla/5.0 (iPad; CPU OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3

****In IE9+ go to settings->Internet Options->Language.

Note1: The credit for this steps is this site: http://www.makeuseof.com/tag/sync-multiple-google-calendars-windows/ Note2: With one more step you do the same thing in Windows 8/RT, follow the link.

share|improve this answer
1  
Thanks, this worked for me! Don't forget to re-enable javascript when you're done. –  Matthew Feb 2 '13 at 18:17
    
Does this work, even after Google ended their support for Exchange ActiveSync? –  Jacob Apr 12 '13 at 13:25
    
@Jacob I did this last monday. It worked. –  Vitor Canova Apr 12 '13 at 19:58
add comment

Thank you! This worked for me, perfectly. I did it using chrome where changing the User Agent and disabling Javascript is a little easier than IE8 (standard at work).

From Chrome:

Hit F12 to see developer view

Click on the little gear on the lower right hand corner of the screen

Under Settings: Click check box next to User Agent and choose IPad IOS 5

Under General: Click check box next to Disable Javascript

Josh G.

share|improve this answer
add comment

As of today I could not get any of the posted solutions to work, it might have to do with the fact that I've got a Google apps account.

The procedure that worked for me was simply to go through the iPhone guide provided by google, and end up at https://www.google.com/calendar/syncselect and choose the calendars I wanted to sync! Here it is possible to choose the additional calendas to syncronise to your devices.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.