Take the 2-minute tour ×
Windows Phone Stack Exchange is a question and answer site for enthusiasts and power users of Windows Phone OS. It's 100% free, no registration required.

I have a Nokia Lumia 630 and recently the system clock keeps changing, every time I reboot the phone, to like 1 a.m. on Saturday 30th of May for instance.

Its getting quite frustrating as its happened about 5 times.

share|improve this question
    
Do you have automatic update of date and time enabled? Check settings -> date+time. –  Indrek Jun 10 at 6:48
    
Yes. Is it because of that? –  Vivek Parekh Jun 10 at 6:49
    
Could be. Try disabling it and see if that works. –  Indrek Jun 10 at 6:49
    
It worked! Thanks :) –  Vivek Parekh Jun 10 at 6:51
    
Good to hear. I've posted the solution as an answer. –  Indrek Jun 10 at 6:55

1 Answer 1

up vote 3 down vote accepted

If you have automatic update of date and time enabled, it could be that your phone is getting incorrect info from your mobile operator.

To disable automatic update of date and time, go to Settings → date+time and disable the "Set automatically" option. Then set the correct date, time and timezone manually.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.