I have a HTC Trophy and for some reason it doesn't install properly when I plug it a computer. I've tried on 3 different computers but it shows in Device Manager as an unknown device.

I've had the phone for at least a year now and it was working fine when I got it. It came from Vodafone, and was branded by them but not locked. I've used my giffgaff sim card in it from the moment I got it and as I say it worked fine when I plugged it in the computer.

Since then I've formatted my PC numerous times so the driver definitely needs to be reinstalled.

Zune doesn't pick it up at all - and I've noticed when I plug it in it vibrates and then vibrates again? I don't think it used to do that.

The only reason I want to connect it is to get all my files off of it as I have a new phone. So I'd rather not reset it at all either.

Does anyone have any suggestions on how to get the phone to install properly?

P.S. I've also tried manually installing the driver, using Microsoft's FixIt tool, and as I say I've tried on numerous computers. Is it note worthy that I've had this phone plugged into a Mac before? I don't know if that could have caused any problems.

I have taken the phone apart to get to the damn SD card. I've tried putting the Micro SD card in a SD card reader, but 'nowt.
I know the SD card slot and adapter works because I tried another SD card too and it picked it up fine. I'm guessing it's because of the filesystem or something? even EASEUS won't pick it up though so I'm going crazy right now.
If no one knows how to fix the problem above, does anyone know how to get access to the SD card?

  • Could you instead add the files you need to get off to SkyDrive?
    – Rowland Shaw
    Oct 5 '12 at 15:14
  • Unfortunately not, I tried that. I have videos I'd like to save too and it they're too big in file size. Nice suggestion though! Oct 8 '12 at 8:44
  • What about drop box...I think there's a windows phone app for that. Oct 14 '12 at 2:33
  • I'll have to double check but I don't think it lets me save my videos. Oct 15 '12 at 8:33
  • 3
    You can't read the sd card, it's been formatted specially by the phone: windowsphone.com/en-us/how-to/wp7/basics/sd-cards-and-my-phone. It kind of sounds like the USB port on your phone is messed up - does it charge normally?
    – Jac
    Dec 19 '12 at 1:36

I've seen this happen with cables. Find the original cable, or try some other folks cables. If you look hard at the end of the usb cables you'll see they actually have different number of pinouts. Try ordering a true HTC Trophy cable from http://shopamerica.htc.com/accessories.htm?prId=39028 . G'luck.

  • I've been trying the original HTC Trophy cable, and after that didn't working (after trying everything I've mentioned) I tried it all again with at least 2 other cables. Dec 13 '12 at 17:13
  • Next step, I'd try it on another buddies machine. Also make sure the port you're using is USB 2.0 , not 3.0.
    – Joe Healy
    Dec 14 '12 at 18:34
  • I've tried on 2 laptops, 3 PC's and eventually a Mac. Still no go :/ Thanks for the suggestion though! :) Dec 21 '12 at 12:21
  • Although I have a Samsung Focus (1st gen), I've had I don't know how many cables "go bad," including the original one that came with it. Also, some cables are "charge only" but often don't say that on the packaging. Just $.02 worth of experience. Feb 18 '13 at 15:11
  • It was definitely a data cable - I had tried around quite a few different cables in the end too. Eventually I sold the phone to o2 recycle. Apr 9 '13 at 11:05

I've suffered having the same issue and finally steps from this page helped me solve my issue when Zune didn't connect to my device proply. Issue was caused using ForensIT's User Profile Wizard, which allow switch existing local Windows accounts into Active Directory ones.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.