5

I have a Nokia Lumia 720 phone which is up-to-date (I just checked it before typing here) and am using Windows 8.1 on it (OS version: 8.10.14219.341). I frequently get my mails on Gmail and so I wish to access my emails from my phone.

Here's a flowchart of what I did to set it up: Phone > Settings > Emails & Accounts > Add an account > Google > Connect > Nothing happens after I see 2-3 dots going from left to right which signifies waiting, and then I land up in the same page.

After this, I tried using Other account (POP and IMAP written below) and then entered my Gmail account details and clicked on sign in. Again, nothing happens. Just after this, I use my laptop and login to my account and find a mail I received from Google telling me this:

Hi XXXXXX,

Someone just tried to sign in to your Google Account XXXXXXXX@gmail.com from an app that doesn't meet modern security standards.

Details: XXXXXXXXXXXXXXXXXXXX XXXXXXXXXXXXXXXXXXX

We strongly recommend that you use a secure app, like Gmail, to access your account. All apps made by Google meet these security standards. Using a less secure app, on the other hand, could leave your account vulnerable. Learn more.

I tried to find Official Google mail app in the app store but could not find any. The one with the highest rating is not by google and so I assume would be less secure and I did not bother to download and check it. Besides, the rating is pretty bad.

Also, I came to know that POP and IMAP are not that secure and easily breachable. I also tried using Advanced Setup instead of Google and I had to select the kind of account that I wanted to set up: "Exchange Activesync" and "Internet email". It says if you are not sure, contact your service provider to inquire about the right option to select.

Am I going in the right direction? Which type of account should I choose? Would there be more fields I would need to fill up if I select one of those and would they have any security issues later? How do I proceed now?

  • 1
    I don't have Windows Phone to test, but I stumbled upon this question and was quite curious about this issue.This article explains steps-by-steps to do that, which I think is quite up-to-date (May 2015), but I assumed that you got stuck after selecting Google, which the article might not be a help... – Andrew T. Sep 3 '15 at 2:29
3

Google has no love for Windows Phone, and has decided to show this by turning off Exchange ActiveSync support for new devices (last I checked, it still worked for devices that had been set up before the cutoff, though... even though that was around two years ago). Because of this, MS changed the way that they connect to Gmail accounts for WP8.1. The new method also does not use your username and password directly every time it connects to the server; it instead uses an OAUTH token which is unique not only to your account but to that specific phone (this is useful for things like disabling access from a phone later, if you want to do that). That's what the "doesn't meet modern security standards" bit was about; IMAP still uses password authentication.

The steps you listed in bold text are the correct way to set up a Gmail account on the phone. I used them myself, and they worked for me. The phone will open the Google OAUTH (single-sign-on) page for you, and ask you to log in. When you do, Google will then confirm that you want to allow the phone to access your Gmail account. Once you agree, the page will close and the phone will finish setting up the account, using the access token that it got from the page.

It sounds like this didn't happen for some reason. I'm not sure why that would occur. Obviously you need data access for this process, so make sure that's working... beyond that, I don't really know what is going on. Reboot the phone and try again, I guess, or try switching between cellular data and WiFi.

Alternatively, if you want to use IMAP, it's still possible. IMAP isn't actually that much less secure - the password is sent to Google every time the phone connects, which is not ideal, but it's sent over TLS so it's still pretty darn secure - and you can tell Google to let you use such apps easily enough. Go to https://myaccount.google.com/security and scroll down to the bottom of the page (after signing in, if needed). Toggle the option "Allow less secure apps" to "ON". Then try signing in from the phone (or other machine) again.

  • Hi @CBHacking Finally I have synced my phone with my gmail account a few days back. Turns out that the real culprit was internet connection I was using. It didn't install while I was on mobile data pack but worked out in the end after I shifted to WIFI connection. Just wanted to inform you. Anyways, I will accept your answer now. – Jony Agarwal Dec 17 '15 at 9:10

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.