Whenever I take a picture, the lumia camera (or just the regular camera app) always says "Saving" on the screen and I can't get rid of the text in order to take another picture. The phone does save the picture (as a .jpg.tmp file) to the SD card. Even if I delete or rename this file, it still shows "saving" on the screen when I try to take a picture. This persists even after restarting.

Here is a screen capture of what gets shown:
Screen capture of "Saving" shown

I would prefer not to do a reset if possible. I am running build 10536.1004 on a Lumia 1520. Camera app version 2015.1064.11.0

  • Are the pictures being saved to phone memory or SD card? If the latter, perhaps the card is faulty. Try formatting the card, or saving the photos to phone memory instead.
    – Indrek
    Oct 5, 2015 at 5:37
  • See also: windowsphone.stackexchange.com/q/8632/106 (although restart fixes that issue)
    – Rowland Shaw
    Oct 5, 2015 at 8:03
  • I eventually just ended up doing a soft reset and it fixed the issue. If anyone is worried about the pictures being deleted, they were still saved for me. You just have to go into the location where you saved your picture and rename the file from .jpg.tmp to .jpg and you are able to see it.
    – aman207
    Oct 6, 2015 at 18:53
  • I'm surprised to see that this is still a problem for MS. Now, the .jpg.thumb files are all that are available on my Windows 10 phone after the camera app gets stuck "saving...". But worse than that is the fact that the .jpg.thumb files are low quality. All of the high quality photos I took in the last hour are just gone. Sep 10, 2016 at 1:20
  • @DavidRector Are you on the fast insider preview? I haven't had this issue since I made the post
    – aman207
    Sep 10, 2016 at 1:39

2 Answers 2


I found a way to fix that. If you try to restart the phone (or remove batter) u will notice that this message "Saving..." will continue to be issue.

But if you make a soft reset/restart (will NOT delete data on your phone), for example for my Lumia 930 is press & hold Power + Volume down buttons - wait 10 seconds - and the phone will restart, this should be fixed.

It works! I don't have this problem anymore.

  • Soft reset worked for my Lumia 1520
    – rohit
    Nov 11, 2016 at 2:23
  • It also worked for my 930. Thanks.
    – lkessler
    Dec 26, 2016 at 1:02
  • Worked on my lumia 930 as well. Thank you! Jun 23, 2017 at 6:41
  • It didn't work for Lumia 640 lte. It just solves the problem temporarily. After a few shots camera app stops again.
    – rostamiani
    Feb 21, 2018 at 8:06

I have fixed this problem removing the sd card safely from the phone. Opening the sd in a computer, and performing the simple win32 command chkdsk /F of the drive letter where the sd is being used in the computer. It seems the sd flag of integrity is very fragile in Windows 10 mobile, and the only way I can really "fix it" is the real chkdsk from the old MS-Dos school.

Not the answer you're looking for? Browse other questions tagged or ask your own question.