I have Waze installed on my Windows Phone, and it worked well - until today. Now every time I open Waze it quits right away. I didn't install anything on the phone that caused this...

I've tried:

  • Restarting the phone - same
  • Uninstall and re-install Waze - same (even before entering my account)


  • Nokia Lumia 920
  • Windows phone 8.1 Update, OS version: 8.10.14219.341
  • Firmware version: 3051.50009.1451.1004
  • Hardware version:
  • Waze version

Cross-post in Waze forum


It was resolved today, and other people confirm on the linked Waze thread. Probably a server side issue.

  • Please mark you answer so that your question will be marked as answered.
    – Kolappan N
    Apr 24 '17 at 13:01

I had a same problem with Lumia 930 and waze. Was updated last week and now it is working. Only the linking with Facebook is still broken.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.