When I send a SMS to a contact who has two numbers,Windows Phone doesn't give an option to choose which number should receive the SMS. Why Windows Phone doesn't ask me to choose which number I want to send the SMS and sends automatically to the first number to given contact? Is there an option to control this feature hidden somewhere?

My phone: Microsoft Lumia 640 XL with Window 8.1

2 Answers 2


It depends on how you send a SMS. There are 2 ways to create a new message. Method 2 will provide the solution to your problem.

Method 1 :

  1. Open the Contact profile either from People app or Call history
  2. If you have 2 numbers stored in the same profile/contact you will see only one text button below.

Sample contact profile - WP

Clicking on this will send the Message to the first number in the mobile category.

Note : Text option is not shown for number stored in Home category even if it is the only number present.

Contact profile - No text option

Method 2 : This method is a solution to your problem too.

  1. Open Messaging app.
  2. Click on the plus sign located at the bottom.

New message

  1. Now type the contact name at the top. As Rowland Shaw said it will Auto suggest contacts numbers. As you can see in the picture, both numbers of the contacts are shown.

Auto suggest in message

Now you can select a number to send message to.


Normally when typing a contact's name, you'll get an auto complete list of all the matches, with all the numbers for those matches - you can then choose to send to (say) their work number or their mobile number, etc.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.