4

I've set custom ringtones for calls and texts on the contact, but every time the person calls or texts me the default sounds still play. What could I be missing?

Phone: Lumia 950
OS Build: 10.0.10586.164

Update: The per-contact ringtones seem to be working now (cause uncertain - maybe it always was) for calls. But texts are still getting it wrong.

  • 1
    Just checking: does that client show up correctly when they call? On the incoming call screen and in the call history, ideally. If not, that means the phone just isn't matching their phone number with the incoming phone number. – CBHacking Mar 27 '16 at 8:05
  • @CBHacking Yeah, the caller ID works fine. – Iszi Mar 27 '16 at 19:12
  • Hmm... it works for me, on the two contacts that I have custom ringtones for. I'm on the Insider Fast builds, though; maybe it's just a bug in your version that will get fixed in the next update? Not sure. – CBHacking Mar 27 '16 at 21:33
  • @CBHacking See update. Calls work fine now (though I'm not 100% sure they were broken to begin with - most of the testing I was involved with was for texting) but text ringtones are still using the global setting. – Iszi Mar 28 '16 at 14:20
  • here on BLU WIN HD LTE is still having no luck with custom contact text ringtones, initially from google searching i thought it was because it wasn't Nokia/Microsoft hardware, but now i see it doesn't matter. Has there been a fix for this yet? – Cain Kamikazi Dec 2 '16 at 4:40
1

I'm using same OS Version on Lumia 730 Dual SIM. My recommendation is go to people app, select contact for which you want to assign ringtone, select edit option & assign desired ring tone. However I've never tried this but I think it should work. Also check if people app is made to work in Background in Background app settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.