I am using a Microsoft Lumia 640XL, running Windows Phone 8.1 Update 2. About 3 weeks ago, my Lumia Camera app started taking long to take photos. I would click on the capture icon, and then it would highlight on the icon, for a couple of seconds, then snap a photo. Sometimes I would capture something, and it would take more than 10 seconds "Saving" the photo, which I believe is not normal.
At first, i thought it was because there was too much stuff filling my Micro SD card that was causing this problem, so i deleted and moved a few content to free up space. Nothing changed, but anyway, i could live with a little delay as the camera didn't do this often, maybe after i had taken a lot of pictures.

But then, two days ago, I was capturing something, and then the camera just froze with "Saving" showing on the screen:

enter image description here

Not even the camera controls were showing. So I resorted to the most basic method of resolving an app problem: removing and reinstalling it..!! That did not resolve anything. On reinstalling it and opening it, it shows the whatever is behind the camera, and the same text and loading ellipses as shown in the above image (without the camera controls again). Tried rebooting countless times, but still, the problem persists.

How do I resolve this. I really need to access and this application.

(PS: I already tried removing and/or swapping the SD card, as well as changing the default storage location of captured photos, but nothing changed. Also, this was not caused by an update. It was working all along, and decided to stop working, not because of any update I did)

  • Have you tried powering the phone off and rebooting it (a.k.a. a soft reset)? – Rowland Shaw May 17 '16 at 11:29
  • 3
    Possible duplicate: windowsphone.stackexchange.com/q/8632/106 – Rowland Shaw May 17 '16 at 11:30
  • Yes, I did reboot it, but nothing changed – kelvinelove May 17 '16 at 12:22
  • 1
    Have you tried with different camera app (e.g. 'Camera360') ? If you face the issue in these apps as well, then I guess you need to try hard reset. – SuRa May 17 '16 at 18:03
  • @SuRa, I have other camera applications like Lumia Selfie, Lumia Cinemagraph, and they're working perfectly – kelvinelove May 18 '16 at 8:05
up vote 1 down vote accepted

I think I found a solution. I removed the MicroSD card and the SIM card, after removing a few apps that were humping my storage (whatsapp, etc), including the lumia camera itself. Then I did a soft reboot, using Volume Down + Power for more than 10 seconds. After that, i reinstalled the Lumia Camera and it worked just fine

I just faced the similar issue, the software was stuck in the Processing...& Saving... state. It won't show the new pic in the photos section as such all new photos can't be taken because they are in processing state. The solution i found Storage state set to photos to phone (just in case the photos were stuck due to SD card issue) Storage state set for new apps set to phone (just in case the installation of lumia camera app saving issue) Uninstall the lumia camera app Off and on the phone Install the lumia camera app Off and on the phone again **Leave the phone alone for 10 mins after the restart Check the photos , those stuck photos should appear New photos taken should be okay after a short processing time (as normal camera) Change back the setting to save to SD card for both new photo and app Take photo again - it should be okay (hopefully) So I think it was not the problem of Lumia camera app (I did a lot of uninstall & install it didn't work, it was not the SD card swapping did that few times, I think the phone was still processing the pics (stuck due to bug) - i had 5 images in queue stuck as Processing mode - it all appeared after ** (the only significant change i did after restarting was leaving the phone alone). Good luck.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.