Even did a reset, but still nothing changed. This is what the issue is:- enter image description here

enter image description here

My Lumia 640 is not connecting to the Microsoft Account, or downloading/updating apps from the Store when it is connected to the Wi-Fi. It works fine on Mobile Data connection. However, all my other devices, such as two PCs, some android phones are working completely fine. I have checked my date/time and even reset it. I have reset my phone twice, and even changed the language and region to that of US together. But still no help. I have checked the settings of my router, and confirmed that there was no blocking feature enabled on it. But still, from yesterday, my phone is behaving strangely. Please help!

Update 1: All the above problem occurs only when the phone is connected to Wi-Fi. My phone works fine on Mobile Data. Please help.

  • Are Date/Time set correctly? – Thomas Jun 16 '16 at 10:06
  • Yup, also, the phone connects to the account when using Mobile Data, not Wi-Fi. I forgot to mention this in the description. i just update it. – Reeshabh Ranjan Jun 16 '16 at 12:30
  • Sounds like something on the Wi-Fi is blocking access to the store - can you log-in/browse via a browser when connected to that Wi-Fi network? – Rowland Shaw Jun 16 '16 at 15:08
  • Interesting, I just encountered almost the same issue with my brand new Lumia 950 that has just arrived. I can't add a MS Account either. – Thomas Jun 16 '16 at 15:25
  • 1
    No. I wouldn't consider it lame. It is the actual solution that solved your problem. If anyone gets the same kind of problem in future they would know to call their ISP's customer care. Many don't read the comments you see. An marked answer would be nice. – Kolappan N Aug 30 '16 at 11:11

I was able to fix this issue by reinstalling the OS through the Windows Devices Recovery Tool. This offered my a newer firmware version for my device, which might have fixed the problem.

You could try doing a simple hard reset first.

  • Hard reset can fix the problem. – GlacialMan Aug 30 '16 at 1:32

Okay guys, this is the guy who asked the question above! The problem was from the ISP's end. There was a technical issue in my area due to which web services of Microsoft and Google got inaccessible. Hence, it reflected in my phone. If you stumbled upon this question anyways, you may try checking if the websites too not open on your PC or other devices. You may want to call the ISP then!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.