4

I am developing a website and need to be able to see what the pages look like at browsers' default zoom levels. Most desktop browsers allow you to manually set the browser zoom level using a menu or CTRL + Mousewheel. In mobile browsers you can pinch the screen to change the zoom level.

The problem I am having is that I can't figure out how to reset the zoom level to its default level on my mobile phone. I am having this problem in Microsoft Edge and UC Browser. The browsers also "remember" the zoom levels from the last time you visited the page, which means reloading the page doesn't help..

How do I reset the zoom level to its default in these and other mobile browsers?

Thanks.

[edit]

My OS is Windows Phone 10 running on a Lumia 635.

2

Update : For some pages Refresh or Clearing cache does not reset the zoom level. For those website click on the location bar and press Enter key or Left arrow that appears in the keyboard.

enter image description here


Clean the cache and cookie data in Edge. However it must not be necessary. Edge resets the zoom level to default when pressing refresh button.

The browser also "remembers" the zoom level from the last time you visited the page, which means reloading the page doesn't help..

I tested it with this website, Microsoft's websites, my blog, Google's website, etc... All of them behave in the same way. Must be a setting/cookie in your website. Try clearing the cookie and cache data in Edge.

  • I just tested Edge again on my own page, as well as random.org, a site I chose at random. If I zoom in all the way, then reload the page, the browser remembers the previous zoom setting and zooms in all the way again. Clearing the cache doesn't help any. Which version of Windows Phone OS do you have installed? What model phone do you have? – posfan12 Aug 25 '16 at 2:09
  • Edge even reloads the extreme zoom after exiting the app and restarting it. (I'm not sure whether the process was still running in the background though.) – posfan12 Aug 25 '16 at 2:16
  • @posfan12 On random.org I had the same experience, the zoom level was not reset to default on Refresh. However I found a solution that is working with the website you mentioned. I have updated my answer accordingly. Take a look. I am running Edge v38.14393.67.0 on Windows 10.0.14393.67 – Kolappan N Aug 25 '16 at 11:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.