5

Text messages don't beep at me:

  • Yes, the volume is up (I can hear when people call me)
  • No, it's not quiet hours
  • Settings below. Is there anywhere else I should look?

enter image description here

enter image description here

  • Do the other notification types (banner, Action Centre entry, vibrate) work? Do notification sounds work for other apps? What's your OS version? Are the OS and the Messaging app up-to-date? – Indrek Sep 1 '16 at 7:23
  • @Indrek, glance screen shows icon, Action centre too. Not sure what banner is. No vibrate. I do get a sound if if the phone is unlocked. Build 10.0.14393.67. Messaging + Skype is v 3.19.1001.0 – Benjol Sep 1 '16 at 7:36
  • 1
    Banner is the little bar at the top of the screen that goes away in a little while. Example screenshot. If sound works when unlocked, try toggling the following settings under System -> Notifications & actions: "Show notifications on the lock screen" and "Show and sound alarms and reminders when my phones is locked". It's just a shot in the dark, but either of these might be suppressing the sound when phone is locked if disabled. – Indrek Sep 1 '16 at 7:43
  • @Indrek, that's it! "Show notifications on the lock screen" was set to false (because I'm not interested in seeing them, just in getting the notification). This now means I had to go into each app and say 'keep private on lock screen'. Seriously falling out of love with winphone with 10 :( – Benjol Sep 1 '16 at 8:26
  • Good to hear it fixed your problem, I'll post it as an answer as well. And yeah, the notification settings are getting rather confusing. – Indrek Sep 1 '16 at 9:15
3

If the sound plays while the phone is unlocked, but not when locked, notifications might be disabled on the lock screen. To change this:

  1. Go to Settings → System → Notifications & actions
  2. Enable the option labelled "Show notifications on the lock screen"

Note that this will do exactly what the text suggests - in addition to the sound being played, the notification itself will also be shown. If you wish to prevent this (for obvious privacy reasons), you'll need to change the notification settings for each app to enable the "Keep notifications private on the lock screen" option. For more information about that option, see e.g. this article.

3

Allow Messaging app to run in background

  1. Go to Settings->Privacy->Background Apps.
  2. Turn on the permission for Microsoft Messaging. (Messaging + Skype for older versions).
  • 1
    Upvote because it sounded like a good idea. But unfortunately it was already set to On... The weird thing is that the icon shows up on the glance screen... but no sound – Benjol Sep 1 '16 at 6:48
  • @Benjol Have you tried changing the sound from Knock (as seen in your screenshot) to something else. – Kolappan N Sep 1 '16 at 6:57
  • 1
    Just tried, no luck :( – Benjol Sep 1 '16 at 7:00
  • @Benjol You could try linking two messaging tiles into one or Unlink them. Next try toggling on/off the settings. If these does not workout, I'm sorry but I have no idea better than Soft reset. It will not erase your data. You could wait for someone else to post an answer before trying a soft reset. I will also update my answer with the above tries so that someone may post a different solution. Let us know if it works. – Kolappan N Sep 1 '16 at 7:11
  • It's a dual sim phone with only one sim in, if you think that might make any difference... – Benjol Sep 1 '16 at 7:20
-1

If you have both Messaging and Messaging + installed, try uninstalling one. It worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.