Am not able to enable live caller id in Truecaller . I tried reinstalling the app and am getting the same error. Please help me ASAP.

My phone is 820 , running on 14936.1000 build.

enter image description here

  • The app must be installed in phone memory for the function to work. Is the app installed in phone memory?
    – Kolappan N
    Oct 14, 2016 at 8:43
  • yes, the app is installed in internal memory! my default path to install app has always been internal. i tried reinstalling 3-4 times too.
    – Ram Raj
    Oct 14, 2016 at 14:19
  • After you cancel this Close popup. Does it(Show Who is calling) remain on or off. If its off call customer care to get it resolved and if its on then check by calling on your phone. See if its working (Showing callerID). I believe this Unknown Error! could be for some other cause.
    – mohit koul
    Oct 17, 2016 at 11:32
  • it doesn't show who's calling, but when i go to the app, i can see who called me.
    – Ram Raj
    Oct 29, 2016 at 7:46
  • Have you tried enabling enhanced search option?
    – Kolappan N
    Oct 29, 2016 at 8:18

1 Answer 1



820: 1. Go to Security > Auto start > Enable Truecaller 2. Go to Security > Permissions > Permissions > Truecaller > Display pop-up window > Accept 3. Go to Notifications > Manage Notifications > Truecaller > Show Floating Notifications

820: For 820: Phone Settings > Additional Settings > Battery > Manage apps battery usage > Choose apps > Truecaller > Custom and in Background Network , choose stay connected.

Alternative solution, Phone settings > security > permissions > truecaller > allow all permissions. After that, go to additional settings > battery > manage apps battery usuage, by default its "standard" make sure to keep it off,

820: Battery settings > Manage background data

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.