2

I have been using a Lumia 540 (dual SIM) phone running WP 8.1, update 2 for about a year with no problems. When I'm away from my WiFi, I enable a mobile data connection, and an H or H+ symbol appears in the status bar (just after the network name) to indicate that a high-speed data-connection (of one or another type) is open.

Recently, I've noticed that the H symbol persists in the status bar even after I have turned off the data connection. (Settings > Mobile+SIM > Data connection OFF.) It is still there even after several reboots with the data connection off.

Any ideas on how to fix this?

  • 1
    This question already has an answer here - Mobile Data Usage gets enabled automatically – Kolappan Nathan Oct 19 '16 at 15:09
  • @KolappanNathan it looks like a different issue, from how I read this. – Rowland Shaw Oct 19 '16 at 15:57
  • @RowlandShaw I have experienced this issue myself. The phone behaves the same way as it is described here. It may be a different issue if the H symbol persists even after enabling WiFi. Let's hear for the reply from Moongazer. – Kolappan Nathan Oct 19 '16 at 16:08
2

Go to Settings -> mobile+SIM or cellular+SIM.

Change the option "For limited Wi-Fi connectivity" to "don't use mobile data" from "use mobile data".

mobile+SIM setting in WP8.1

1

OK, I have the answer, but sorry, Kolappan Nathan, it is not yours, as I already had the option "For limited Wi-Fi connectivity" set to "don't use mobile data." As it turns out, the phone was behaving correctly; I was misinterpreting the display.

The H symbol I was seeing, even when the data connection was disabled, was just after the network name on line 2 of the status bar. When it appears there, it indicates the highest data connection speed available on that network, even if the data connection is off. When the data connection is switched on, the same symbol ALSO appears on line 1 of the status bar next to the network signal strength indicator. It disappears from there if I either: (a) switch WiFi on and connect to a WiFi network, or (b) switch off the data connection.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.