SD card media is not accessible from WhatsApp.

Whereas I am able to select and send photos from Windows - Photos App. (For now, I am using this workaround for transferring photos).

But, when I try to set profile picture, I'll have to copy the photo from SD card to Phone memory and set it. :( Please advise.

Note: In SD Card, photos are available in Pictures folder created by system.

Model : MS Lumia 640

OS : Windows 10 Mobile (10.0.14393.448)

WhatsApp : Latest version (2.16.288)

This issue occurs only in WhatsApp. Hike and other chat apps are able to access all the photos.

2 Answers 2


i faced the same issue that photos are not available from Whatsapp but then i switched off my windows phone 10. Then took out the SD Card and again inserted that SD card into the phone. After that i switched on my phone and guess what that worked. From then i am able to set profile photo as well as share photos from Whatsapp.


Yup it happens. To resolve this you have to go to settings >storage >save locations and have to set default photos directory to your SD card. This resolved that for me. If still problem persists please perform a restart after altering settings. Since the WhatsApp version present on the store is made for windows 8.1 and altered for windows 10 so you may face some well-known issues such as scaling issue, media attachment, extremely slow performance and sometimes tagging problems. What we can do is wait and hope that Windows 10 compatible version will be available soon.

  • Thanks for the suggestion. I altered the storage location and restarted the mobile, already. So the only option I've got now is to wait for WhatsApp team to fix the bugs. For those who face the same issue : If the above mentioned suggestion doesn't workout, try the workaround mentioned in the question. (Copy photos to phone memory for setting display picture,..)
    – Dhivya DD
    Nov 21, 2016 at 9:25
  • Oh I'm sorry 😞 that didn't work. That worked for me so I answered that
    – Hamza
    Dec 7, 2016 at 15:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.