I don't see a "block call" option when I press and hold number in history. The choices are "details", "delete" and "add to speed dial". I'm using a Lumia 521 and WP 8.1.


1 Answer 1


For enabling block number you have to go to Settings > Call +SMS filter Here you can turn ON or OFF call blocking as well as manage blocked numbers and use some advanced settings.

Hope this helps..


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.