12

How can I disable app notifications in Windows Phone 8? Specifically, I'm looking to turn off notifications on a per app basis so I can disable notifications from Whatsapp.

5

With the Windows Phone O.S. 8.1 is possible to disable such kind of notification. Follow this steps:

  1. Go to Settings
  2. notifications+actions
  3. Find the app you want to change the way notifications work
  4. Just change the "Notification sound" to "none". Optionally you can disable the banner too in the checkbox you will find just above. You can go wver further and disable it from show in action center.
3

Go to Settings --> Swipe right and choose background tasks --> Block Whatsapp from running in the background --> Once u exit the application, it will be enabled and say goodbye to Toast Notifications!! :D Glad to be of help

  • And the app will not update in background too. – Vitor Canova Oct 17 '13 at 14:13
  • 2
    @VitorCanova, if OP don't want any notifications, why should it run in background? – N K Jan 9 '14 at 8:00
  • 1
    @NK Good point. I thought more broadly. In the specific case of Whatsapp it will do the work. But the title of his question is not so specific. In case o AccuWeather app disabling background task will disable the toast warning when a big storm is comming and the update of tile weather too. – Vitor Canova Jan 9 '14 at 10:33
1

Usually there should be something like "Notification On/Off" in the settings inside each application but it doesn't look like there is something. Try to go to settings-> swipe to application and block WhatApp if you can find it there.

  • 2
    There's no setting for whatsapp in settings, and there's no 'background tasks' entry for it either. Apparently once you've installed it, whether its pinned or not, you're going to get toast notifications whenever someone decides to send you something, as long as you have the app installed. Could get potentially annoying. I'd send feedback to the whatsapp guys asking for a 'turn it off' feature. – Joe Healy Mar 1 '13 at 0:39
  • 5
    Turn on battery saver. It'll do the trick. – user1869 Sep 1 '13 at 15:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.