3

I'm using Opera's built-in WhatsApp web client. This works well, but after a period of time it disconnects from my phone. All I need to do is unlock the phone if WhatsApp is running or, if it's not, start WhatsApp. The client immediately reconnects.

However, it gets a bit frustrating to keep doing this. Has anyone else had this issue or managed to fix it?

I'm using a Lumia 950XL, OS version 10.0.15235.0.

3

It happened to me just recently on my lumia 640 (windows 10 mobile, OS version: 10.0.15063.968) after whatsapp got updated to latest version, every time i login in my whatsapp for web, it keeps disconnecting, knowing that before the whatsapp update, even when battery saving was ON i never had this issue before.

I solved it by going to settings--> type 'battery' at search bar--> click on 'Battery usage by app'--> at the whatsapp, click on it (default should be 'Managed by windows') change it to 'Always run in background'.

That should get it running all the time, even when battery saving is ON.

  • Thanks for the suggestion! Unfortunately I've moved on to Android so I'm unable to test this. – Tastes Like Turkey Apr 2 '18 at 17:11
  • I see, well.. if you still have your lumia, you can try it out in your free time (so i can get an up vote if it works)..but of course, you will have to register your whatsapp on the windows phone to try it out (whatsapp on your android will be signed out), but then again, you can re-register your whatsapp on the android (whatsapp on windows will be signed out) and things will get things back as they were on your android. – Abdulaziz Hamdan Apr 3 '18 at 2:20
  • Unfortunately I do not have the Lumia anymore. However, since it worked for you (and someone else, judging by the upvote) I'll accept your answer. – Tastes Like Turkey Oct 3 '18 at 14:03
1

I have had the same problem with different Lumia 640s. Only setting the battery usage did not help. This is how I solve it (I do not know which step ultimatively solves it):

  • Uninstall WhatsApp
  • Install WhatsApp
  • Settings--> type 'battery' at search bar--> click on 'Battery usage by app'--> at the WhatsApp, click on it (default should be 'Managed by windows') change it to 'Always run in background' (Abdulaziz Hamdan)

  • Set up WhatsApp
  • Directly configure WhatsApp Web
  • Restart Windows 10 Mobile
0

First of all - is your device always connected to the internet? e.g., when these disconnections happen, is your device connected to a WiFi? If not - did you enable network roaming, or made sure you have a "live" viable connection to the web, which can work while your device is idle (such as receive emails, get notifications from apps, etc.)? If so - then all you have to do is wait a bit. The device will periodically "disconnect" WhatsApp, only to bring the connection up once in a while, depending on how much you use it within a time frame. This happens to me a lot, and if I can't wait for a reply or for my message to send, I'll just "wake up" my device. If not, I'll just wait for the next communication "burst".

I'm also using a Lumia 950XL, v1.0.10.0.

0

Chances are you use your phone whilst in battery saver mode. Battery saver mode restricts and or shuts off some background events, and hence causing applications, in this instance, WhatsApp, to only run when opened.

Also, restricting background data has that effect too. Consider changing those options, and you will see everything working just fine

  • That's a good thought, but unfortunately this is happening while my phone is plugged in, at 100% battery life. That said, I haven't noticed the issue since the latest update. – Tastes Like Turkey Sep 25 '17 at 2:41
  • Have you tried removing and reinstalling whatsapp? – kelvinelove Sep 25 '17 at 14:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.