enter image description here Phone:Lumia 640XL DualSim OS: Windows 10 with latest October 2017 update (regular version, not slow or fast ring or anything)

The problem has persisted many times before for many months and it was only solved by doing hard reset and then downloading and syncing everything and setting up my start screen and apps all over again. I guess i don't wanna do that anymore so please help me out.

While the camera works fine for a few weeks, suddenly this starts happening:

As seen in the picture above, all the photos taken with Windows 10 camera app are saved in 720x960 resolution only. When I take photos in Camera app and go to last taken photo by clicking on thumbnail icon, I see the text "Adding finishing touches" above the images and it never finishes. So after waiting for about 5-7 minutes, I minimize the camera app and go to Photos app, and the images are there, but in low resolution. And then, if i close the camera app, start it again, and go to its preview gallery, the 'Adding finishing touches' has disappeared and photos are in low-res now. I went to the file manager app, to the camera roll folder in memory card, and there are few .tmp and .thumb files. I rename them back to .jpg and they become the same images i took, but again in same low res. I also kept the classic Lumia Camera app when i upgraded to Win10, and kept its update pending in Windows Store so it still works, with its bracketing function and everything. The only problem is, when the low-res issue happens to main camera app, it also happens in Lumia camera, and if I take a photo and go to image preview from its corner thumbnail icon, it again shows the image "Processing" that goes on forever, and yet it appears in photos app with same low res, and few more .tmp and .thumb images in camera roll folder.

enter image description here

One more thing: If i scroll back on the "Lumia Camera" preview gallery, there are about 4-5 blank images from past showing "processing" written above them. There aren't visible in regular camera app preview gallery, or under the Photos app or in file manager Camera Roll. Even if i delete everything in Camera roll folder, those blank images in Lumia Camera gallery under processing still persist.

I tried taking pics after turning on RAW capture (by using interop tools) but results are same. There is no RAW file saved in camera roll. I tried taking out memory card and saving pics to phone memory, still same results.

And if I try to hold the shutter button (in both Windows Camera and Lumia Camera) to take many photos in quick succession, it shows "Saving..." And doesn't take any more photos. I can do a soft reset to fix that so camera apps start taking pics again, but that low-res situation still exists.

However, if I try using other camera apps like Lumia Selfie or ProShot (paid version) I can save full res images and they work just fine. However for some reason in Lumia 640XL (both Win8.1 and Win10), even the paid version of PrpShot or any other manual camera app doesn't offer RAW capture or full manual control over shutter speed. I can only change ISO and focus.

So here os what I've already tried: -Restarting/SoftResetting the phone (only fixes 'Saving... Issue not the low-res issue) -Using DNG capture -Taking out memory card, fixing errors using PC card reader and putting it back -Fixing memory card using Win10 mobile inbuilt error checking. -Taking out memory card altogether and using Phone memory to store photos. -Updating camera app as new update showed up. -Using 3rd party apps (but i lose RAW and 4sec shutter speeds and manual controls)

Only solution is hard reset but I'm thinking there must be some other way, changing a registry value or trying something with phone (Its fully unlocked with access to Windows system files in Phone Memory when connected to PC) Please help me out here.

  • 2
    Update: In the same registry folder where i can turn on DNG capture (by setting DNGDisabled from 1 to 0) there is another entry called "IsEnabled". If I change that from 1 to 0, the main camera app starts working again, and it's now even better. It can take as many photos as I want in rapid succession without crashing or prompting "saving". And it doesn't show "adding finishing touches" anymore and photos are saved in full resolution, and can be previewed right away. – Uday Singh Oct 22 '17 at 9:54
  • 1
    But the problem with IsEnabled=0? I cannot use Lumia Camera app anymore (even on Windows 10 its asking for 8.1 Denim update), plus all manual controls are gone. I cannot set 4src shutter speed anymore. I mean i can change it but when taking pics it just uses auto setting as if i never changed anything. And RAW capture is gone too. The option to turn on/off DNG in camera settings has just greyed out. Guess there is no way to simply use a default camera app the way i wanna use it. Microsoft sucks. – Uday Singh Oct 22 '17 at 9:57
  • Thanks! I had the same issue and this fixed it for me! I was already mentally preparing for a hard reset... – katti Dec 13 '17 at 12:36
  • I would suggest you add this as an answer, even though it's your own question. :) – katti Dec 13 '17 at 12:36

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.