17

My Lumia 920 runs out of battery in around 6 hours. I have full battery when I leave my home in the morning at around 08:50 and at 14:33 it's empty (Battery Widget). I have disabled all background programs at settings -> Programs -> background tasks. I have also disabled push notifications from mail and Facebook.

How can I increase the battery life? I need to have my phone working at least 12 hours a day with small tasks.

  • 1
    How many email accounts do you have? Have you tried changing your email frequency like in this answer windowsphone.stackexchange.com/a/554/295 ? – row1 Apr 4 '13 at 12:52
  • one outlook account, syncs every 30 min, maybe 3-5 mails each day, i dont think this is enough to draw the battery. – Remi Champ Apr 4 '13 at 13:12
  • 1
    When I first got mine it would drain fast too. I did a total drain, ran that battery as dry as I could till the phone wouldn't try to turn on. Then did a full charge and it has been working pretty well. Now when it seems to be draining fast I power off my phone and turn it back on and it seems better. Must be something in the background hung up. – Wayne In Yak Apr 4 '13 at 19:29
  • hmm, okay.. I will give that a go and see if that will help any. When i first got it, it worked fine. – Remi Champ Apr 4 '13 at 20:52
  • As I cannot add new answer, here is at least a comment: Use Battery Discharger once a while (when you see battery life decrease) and discharge your phone fully. Then charge again and you should be in better shape. The reasoning behind it is battery capacity counter is decreasing over time and with this it is reset to its maximum capacity. – Lukas Cenovsky Aug 11 '13 at 20:28
17

Search for "Battery" in the Windows Store and pick up one of the free battery monitoring programs that displays a graph of you battery usage by time. (The one I use is called Battery Sense, by Vasan Jiaramaneetwesin).

Let that run in the background and try to remember what apps you run during the day. The graph will show you what rate you're using your battery up, and certain apps and other actions with the phone use more juice than others. This way you might find one or two apps that are using up much of your battery.

Here's other things to try:

  1. Decrease screen brightness
  2. Disable wi-fi when you're not using it.
  3. Turn off Tap+Send (this actually uses a lot)
  4. Games: Turn off both "Connect with Xbox" and "Sync game requests".

If your phone is new, battery life will not be at the maximum until you've recharged about a dozen times.

  • Good, i will give this a try and see what happens. I all ready use battery widget (free), to give me a overlook on the burn time. – Remi Champ Apr 5 '13 at 8:22
  • 1
    wow that worked! i turned off Tap + send and games sync, now it has only gone down 5 % in 3 hours! – Remi Champ Apr 5 '13 at 12:05
  • @Remi - I have basically just turned those two off as well, and I typically have plenty of juice for a full day. – lkessler Apr 5 '13 at 20:58
  • yeah i have about 15+ hours battery life now. Thx! – Remi Champ Apr 6 '13 at 17:38
  • 2
    Good stuff, here. I'd add turn off bluetooth and location services when you're not using them. I'm quite obsessive about only enabling features when I need them and only for as long as I need them (e.g.: If I want to check in to Foursqure, I turn on location services, do my check-in, and immediately turn location services back off). Usually, this lets me stretch my battery out for a whole day without even hitting the Battery Saver threshold. Get Connectivity Shortcuts to help you get in & out of these settings screens fast. – Iszi Apr 8 '13 at 2:36
4

Even with all the usual suspects taken care of, my 920 will sometimes get warm out of nowhere and start draining battery like crazy. I suspect some sort of firmware issue. In any case, when that happens just do a battery-pull reset -- hold the volume down and power buttons until the phone vibrates. I have to do this a couple times a week; an annoyance, but a very small one.

2

The first weeks I had the same problem, but at some point, after a month or so I did't experience this problem. I turned of some background services for a while, but now I use sync every 15 minutes and allow all kinds of background services. I think you have to use it for a while for it to be great!

protected by Vitor Canova Jul 7 '13 at 13:15

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.