4

On my Nokia Lumia 620, whenever I try to connect to a secure wi-fi network that uses WPA2 Enterprise for security and 802.1x (PEAP using MSCHAPv2) as its authentication method, I get an error message saying "could not reach wifi network" even though I know it's in range and I know the password is correct.

This seems to have been reported earlier on the Microsoft Answers community as well as news sites. That was for Windows Phone 7 though. Does the same bug exist to this day, and if yes, is there any workaround for it?

  • Did you manage to solve this? – user1977 Sep 23 '13 at 23:38
  • @HaLaBi Nope :/ – Ankur Banerjee Sep 24 '13 at 12:09
  • I think it will be fixed in GDR3, along with TTLS suport – Arcadio Garcia Oct 1 '13 at 10:00
3

This is fixed in GDR3 update - make sure you have updated your phone to at least 8.0.10512.142

If your carrier doesn't have the update you can get it the following way:

EDIT: THIS WILL VOID YOUR WARRANTY

  • · Go to http://apps.windowsstore.com and login with Microsoft Live ID.
  • Tap on OS Preview for Developers ·

    Scroll down and click on Download button, it will take you to “Preview for Developers” app screen ·

  • Click on install , it will initiate install on the device remotely if not It will send the mail to the same account, open the link to install the app ·

  • Install the app and accept terms and conditions and go check for
    updates again from settings screen. ·

  • Boom you will be on GDR3

J

1

This was resolved in the end by two different things, and I'm not sure which one was more critical so I'm mentioning both:

  • I got the GDR3 update
  • ..and more importantly, my company deployed a mobile device management (MDM) solution that automatically downloads and installs company certificates which are used for authentication on the WiFi network.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.