I have a Lumia 521 phone with Windows 8.1. Recently the phone started to malfunction for some reasons and in the process lost some of the Application data. The app is a Notes App (KeyNote) that had my notes for several months and none of my earlier notes are being retrieved. I found that the only way to access internal folders in the phone (where the app data could be possibly found) is through interop unlocking my phone.

I tried some of the tools to try unlocking it here with the help of posts here or the one below but no luck.


Please help as I am in need of the data.


  • Do you have an SD card for the phone? One way to interop-unlock WP8.1 was via the SD card and hijacking an OEM app. Another option is to use WPInternals to unlock the phone's bootloader and enable USB Mass Storage mode; this is riskier though (may need to hard reset). The technique given in that link is probably usable but pretty awkward, and might not work on fully-patched phones. – CBHacking Jul 26 '20 at 4:35
  • There's an SD card for the phone. I can surely try this one of using WPInternals to unlock the phone's bootloader to enable the USB. Can you please help in providing more info on this? Appreciate your help! – Karthik S Rajashekar Aug 5 '20 at 18:20

Please bear in mind that it has been many years since I worked with WP8.1 and I have forgotten some details. However, I'll do my best.

Also, be aware that it's entirely possible that the data you seek is gone forever. Neither of these approaches will give you the ability to magically "undelete" files (you can try using a file recovery tool if you do the USB Mass Storage route, but if the files were deleted some time ago they've almost certainly been overwritten).

Finally, note that these instructions assume the app in question was installed to the phone's internal storage, not to the SD card. There are variations on the instructions that might work if the app is on the SD card, though that's actually harder to recover in some cases (the app data on the SD card is encrypted; not hard to defeat the encryption but it can complicate recovery).

The SD-based interop unlock worked by moving some OEM app from the store (one that had ID_CAP_INTEROPSERVICES) to the SD card, then using a sideloaded app to hijack the app on the SD card (there's a process there, but it was mostly automated by the end, just install and run the relevant apps). That gives access to the hijacked app's capabilities.

A full tutorial for the SD-based approach is here: https://forum.xda-developers.com/windows-phone-8/development/interop-unlock-oem-unlock-windows-phone-t3467191. Note that this hijacks the "MixRadio" application, which is pre-installed on Lumia devices but was discontinued long ago; if you uninstalled it at any point than some modifications are needed. The tutorial says to hard-reset as the first step (so you get the over-privileged MixRadio app back) but that's obviously not viable for you. Here's a slightly older tutorial that uses Nokia's "Extras + Info" app (normally present in Settings IIRC, but technically an app): https://forum.xda-developers.com/windows-phone-8/development/tut-interop-unlock-root-wp8-8-1-windows-t3450239. That one doesn't require any hard resets but is a bit more convoluted. If neither of those work I can try walking you through the process for manually hijacking an app chamber, but it has been many years since I did that and I don't have a WP8.1 device to test on; I'd be going off my old tools and forum posts.

Alternatively, you can use the WPInternals tool, which allows unlocking the bootloader of the phone. Note that if the phone's file system is encrypted (BitLocker), this will not do you any good!

In the tool's earlier days you often had to re-flash the entire OS image (which of course erased all user data), but these days it is in theory possible to overwrite only the portion necessary to allow booting the phone to USB Mass Storage mode, after which you can connect via USB and browse it like an external hard disk with full access to all data. I must stress IN THEORY because this is very "hacky" and does not always work perfectly, and there's a risk of it putting your phone in a state where the only recovery option is to reflash it. That gets you a working phone again, but at the cost of all your data.

The tool is introduced in this post: https://forum.xda-developers.com/windows-phone-8/development/windows-phone-internals-unlock-t3257483. However, note that that's a VERY old post. These days, unlocking the bootloader and enabling USB Mass Storage mode is quite easy on supported devices, assuming the tool works correctly. The download is at https://www.wpinternals.net/index.php/downloads,

Assuming you successfully get the phone unlocked and into USB Mass Storage mode, it becomes possible to browse the file system; the data you're looking for should be in a folder on the Data partition. The path will be something like \Users\DefApps\AppData\Packages<IDENTIFIER_STRING>\Local, although I almost certainly have some part of that path wrong. Poke around until you find it. DO NOT try to write to the phone's file system (including stuff like opening a file and saving changes, renaming a file or directory, or editing the access to a directory). The identifier string will either be a GUID (if the app is old), or a text string that probably contains something related to the app name followed by random characters (for example, the ID string for the Windows Mail / Outlook app is "microsoft.windowscommunicationsapps_8wekyb3d8bbwe"). Figuring out the right app - especially if it's an old one with a GUID instead of an ID string - may take a lot of guesswork.

In either case, it might be hard to tell what you're looking for. If the app stores its data in simple files (plain text or a common format like a JPEG image or something), those will be easiest to recover but are the least likely for the app to have lost them. If the data are stored within a structured file system hierarchy without clear names, it's probably possible to find them but might take a lot of looking. If they're stored in an archive (such as a ZIP file), you won't be able to find the data themselves just by looking in the folder but you might find the archive and open it with something like 7-Zip. If they're stored in a database (such as SQLite), then you'd need to extract the DB file and use another program to pull the data from it; this can be complicated.

  • The first method to use extra+info's hack was not viable since the Nokia update is not available from the store anymore (for 8.1). Trying with the alternate WPInternalsTool. Phone was recognized but the mass storage was not unlocked to enable root access. While I continue to explore ways of enabling root access, any other suggestions are welcome. Really appreciate the multiple approaches that provide detailed explanation to the issue. Thanks so much! – Karthik S Rajashekar Sep 19 '20 at 16:23
  • With the WP Internals tool, the root access is not getting enabled on the phone. The boot-loader needs to be unlocked for dumping the ROM. Tried this option too, the source-FFU file is not downloaded either with the Product/Operator code. After trying the recovery steps, is the hard-reset of the phone to a factory settings an option? – Karthik S Rajashekar Oct 24 '20 at 15:55
  • Yes, either hard reset or re-flashing the device using the Windows Device Recovery Tool (free download from MS) will work. However, it will erase all user data on the device, so don't do it unless you have to. – CBHacking Oct 25 '20 at 6:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.