Presently all birthdays for all my Facebook contacts appear on my phone's calendar. At one point I had all Facebook contacts available on my phone, but I've since filtered them so that only those contacts that also exist in either Live or Outlook show up. I was hoping that birthdays for Facebook-only contacts would also get filtered, but this is not the case.

Ideally, Facebook birthday information would show up, but only for Live/Outlook contacts. Is there a way to achieve this? If not, what are my other options for limiting which contacts show up in the Birthday calendar?

  • 2
    My lord how irritating that is...I get a good 5-10 reminders a day about birthdays. Apr 30 '12 at 2:43
  • How did you filter your Facebook contacts? I have a few Facebook contact whose faces I would rather not have peering at me on my start screen
    – paradroid
    Apr 30 '12 at 9:28
  • @paradroid that sounds like you might want to ask that as a separate question...
    – Rowland Shaw
    May 2 '12 at 12:19

I don't think you can selectively remove friends from the Facebook calendar, but you can turn the whole thing off.

When looking at your calendar touch the ellipses (...), choose Settings and choose what calendars you want to display. You can even select a specific color for each one.

I know this is not ideal, but maybe it is good enough. Perhaps you just add the birthdays you care about to another calendar.

  • Thanks for the response, Joe. I was hoping for a less drastic solution than turning it off completely. Apr 26 '12 at 16:28
  • @DanielPratt yeah I know. As of now that is pretty much your only option....well you get un-friend all those people on facebook :P
    – user131
    Apr 26 '12 at 16:29
  • I just did a look through the calendar options on www.live.com and on facebook.com and it doesn't give the option. What it does is scrape your Facebook contacts' public information, including birthdays, and that is listed as a required permission on the Windows Live Facebook app permissions page. Unless they provide more customization options in the future, I think it's going to be an all or nothing type of thing, as Joe said. Apr 26 '12 at 20:05

After spending quite some time on it, I have found the solution to your question. It involves dealing with external calendars (Outlook, Facebook) on their respective websites.

First of all, on where the birthdays are stored: when you connect to Facebook on your phone, Outlook automatically imports all the birthdays into its calendar. You can view and edit them on the Outlook calendar website; there's a separate calendar there called Birthdays that you can change.

By default, you are subscribed to the Outlook/Hotmail birthday calendars. This is the setting you can change on the phone.

However, that is not all. Facebook birthdays are also stored in the Facebook calendar. As of today, there is no way to remove them from the Facebook calendar (Facebook doesn't allow that).

These birthdays won't show up on the phone, but you will still be notified about them (this made me search, in vain, for the topic "Windows phone notifies about deleted birthdays").

Nevertheless, Facebook allows one to subscribe/sync to its events and birthdays calendars separately (at least some sanity!), as per their help page. So the solution is to subscribe to Facebook events only calendar from another calendar of your choice (I created a new Outlook calendar), and have your phone display it. Turn off the Facebook calendar entirely on the phone, it is now duplicated on Outlook.

For the summary, I assume you are using the Outlook calendar.


  1. Turn off the Facebook calendar on the phone (... -> Settings -> Calendar(Facebook): off).
  2. Log in to Facebook desktop version. Go to events. Follow the instructions and obtain the subscription link for events (it's the link under "upcoming events" and starts with webcal://www.facebook.com/ical/u.php? ...)
  3. Log in to Live Calendar. If you prefer Live, hit Import, then Subscribe and enter the URL you got in Step 2. Call it "Facebook event sync" or anything you want.
  4. While you are there, edit the Birthdays calendar to your liking (delete birthdays you don't want, delete the calendar entirely, create a new one and put just the birthdays you want, etc).
  5. On your phone: open calendar, ... -> settings. Make sure the calendar you made in step 3 ("Facebook event sync (Hotmail)") is turned on. If you want to turn off birthday notifications entirely, turn off the Birthdays(Hotmail) calendar.
  6. If your phone has Battery Saver mode on, turn it off and wait for the calendar to sync (you may need to go to phone settings -> email+accounts -> Microsoft -> download new content -> as items arrive->OK to force sync).


Turn off Facebook calendar. Delete unwanted birthdays on Outlook, subscribe to Facebook events only from there.


If you have upgraded to the new outlook.com layout;

Go to your online outlook calendar (live.com/hotmail.com/outlook.com) via select Calendar > Birthday Calendar (do not uncheck it click on the title) > Under "Reminders" remove anything you do not want. I removed them all.

This way you could still get email reminders if you want them and just not the outlook application reminders that are very annoying.


I found the solution! Login to hotmail.com > Go to the Calender > Click the textlink Birthday... > There you can erase the entire calender. If you want a empty birthdaycalender again, just create it again..


I opened the birthday calendar on Windows Live, scanned a few months ahead and deleted the birthday events that I didn't want to receive. It's a decent solution.

I don't recall if I did anything special to sync the FB account to Windows Live.


I managed to do it on outlook.com, click on calendar the top right filter option uncheck the birthday calendar. The issue was it still showed all birthdays on my phone. To stop this I had to remove all hotmail/outlook.com reminders which is annoying.

im trying to work out how to disconnect hotmail and facebook as i think that should solve it.


If not, what are my other options for limiting which contacts show up in the Birthday calendar?

Via calendar. Under the calendar app, click more '..." then settings. There you can toggle on and off calendars. You can turn off the Facebook Calendar and see if that removes the birthdays (you'll still get them if you have Facebook contacts linked to your phone live account, but you can remove the contacts you don't want to track).

But maybe you want all those contacts but not their birthdays to show? You can use a combination of accounts to act as filters. I have a phone Windows Account, a personal information Windows Account (Facebook, Family), and a business Windows Account (twitter, linked-in). I can then setup calendars and contact info though their outlook.com accounts and tweak them though phone, outlook.com or outlook 2013 app and have everything sync the way I want. Also consider you can share/subscribe to calendars though live/outlook.com.


Open your calendar. On the top left hand corner, click on 'calendars'. You'll see a list of different calander items including birthdays, just click on birthdays, the checkmark will go away and birthdays won't show up on your calendar anymore

Not the answer you're looking for? Browse other questions tagged or ask your own question.