4

I already asked in other forums, but i guess maybe somebody here is having the same issue.

I'm not receiving Whatsapp notifications or Facebook notifications in proper time, in the case of Whatsapp I only find out new messages when I open the app, but in the meanwhile nothing notifies me about anything, it seems to me that something went wrong with the last update, because the app used to work fine. In the Facebook case, the notifications trough people's hub or trough the official app don't reach me until a few minutes (sometimes hours) after the event and it's really frustrating specially when chatting trough the official app or the people's hub.

Has anyone had the same problem and solved it?

  • What phone do you have? – row1 Aug 7 '13 at 7:21
  • do push notifications work in other apps (eg. Twitter)? – Neil Turner Aug 7 '13 at 18:09
  • Lumia820 SO: 8.0.10211.204 Firmware: 1232.5957.1308.0004 Whatsapp version: 2.10.529 Facebook version: 5.0.3.0 I've search trough different forums and it seems an old problem from days of WP7, I contacted Whatsapp and blamed my carrier (Movistar) then called Movistar and them claimed is an App problem wich i belive because I've had this mobile number for almost 8 years now and is not the first time i use it with whatsapp, meanwhile nobody can offer a proper solution. Contacted nokia and they answerd this: @alfredocg Thanks for the feedback! — Nokia (@nokia) August 7, 2013 – Alfredo CG Aug 7 '13 at 21:25
  • That kind of responses only give worst feelings to users. The Apps that are helping me trough this are Twitter and Line that seem to work fine altough I've seen in other forums these apps have the same problem too. – Alfredo CG Aug 7 '13 at 21:26
  • Seeing as these notifications are push-based it is usually a connectivity issue. What is WhatsApp's Connection State in Settings? – Nik Rolls Aug 8 '13 at 7:05
2

TL/DR:

Go to Settings - Battery Saving. Even if you have the setting here permanently set to Disabled, slide right to Usage and search Whatsapp within the application list displayed. Tap on it and ensure the option to allow it running in background is enabled.

Long version:

This seems to be not related to connectivity limitations like most replies I've found around. In my case at least the issue was due to the WP 8.1 new feature of disabling applications from running in background (application running, not network usage).

The option was well hidden and IMHO very badly UX designed by WP because one would expect the setting to be ignored: if you disable the battery saving settings, you'd hope none of the other options for applications would have any effect!

Disclaimer: my use case phone was set in spanish language and thus the menu names might be slightly different in english.

In my case this setting was enabled for unknown reasons (to me), this was my mother's phone and she might have accidentally enabled the option, or WP might have unilaterally decided that Whatsapp was using too much battery in background mode and disabled it, who knows.

I bet most people out there reporting that a reinstall solved the issue don't realise that it got solved basically because WP lost the setting about the app. As a general rule, whenever an app reinstall fixes an issue, it means you overlooked one setting out there.

This answer is relevant to Whatsapp as this was my specific issue, but I am quite sure Facebook (or any other app) experiencing the same issue would get fixed identically.

Hope you find this useful and you don't need to reinstall.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.