3

After updating to Amber I did a complete factory reset as my "Others" storage was huge.

Then I set all my mail accounts as I previously did, getting all of them working ok (1 outlook and 2 gmail) but the gapps account was throwing errors all the time.

At the end, I discovered that disabling the calendar made it sync; the problem is that I really need the calendar working.

Does anyone know why it's throwing a 801901F5 error if I set up the caldav server to m.google.com and a 8007000E error if I use www.google.com ???

Thanks in advance!

  • 1
    Is it a Gmail or Google Apps account? also, only www.google.com will work for CalDAV/CardDAV. – Neil Turner Sep 29 '13 at 13:49
  • It's a Google apps account... So you mean that there's no chance of accessing my company's calendar with wp8 gdr2? – F.D.F. Sep 30 '13 at 14:41
  • No, but there are differences to how Gmail and Google Apps work, especially with calendars. I'll add my Google Apps account, change some settings and report back. – Neil Turner Oct 1 '13 at 10:08
  • At the end I'm setting up an activesync accountas it seems to work as it used to... I'd like to know how to setup it without that workaround though, as it seems that Google will drop activesync support... – F.D.F. Oct 2 '13 at 10:07
2

I was able to resolve this issue and hence sharing here

Disable Calendar sync in AT&T920 WP8 GDR3 (i don't think GDR2 or GDR3 matters here) to verify that CALDAV is indeed the issue. When I did this the memory errors (8007000E) went away.

Steps I took: 1. I used Microsoft Outlook and Google Apps Sync to get a Local copy of my Google Calendar Data 2. Outlook reported that I had ~26000 KB in my "Calendar" 3. When I sorted the data based on date of entry, I realized that I had VERY OLD i.e. before GMAIL even existed 4. I deleted some old event data using Outlook +Sync. 5. Re-checking, the size of the "Calendar" folder as reported by Outlook was slightly down to ~24000 KB 6. On my 920, I 'enabled' Calendar Sync, and voila ! memory problems went away

Workarounds I was able to use "Google" account for my email and Contact AND "Exchange/ActiveSyn" for the Calendar Steps 1. Go to Emails/Accounts - Assuming you already have Gmail setup via CarDAV, CALDAV etc. with address my.name@work.com 2. Add Account 3. Select 'advanced setup' 4. Input any arbitrary name that is different from 1. above for e.g. mynameis@work.com, add password 5. Click Next and choose 'Exchange ActiveSync' 6. On this screen. continue to use the email address as in step 4. However, for User Name enter your Google Calendar ID - For most people this is = your email address i.e. same as step 1. i.e. my.name@work.com 7. Leave domain as blank, enter the server as www.google.com 8. Uncheck, Email, Contacts etc.

DONE! Now you should have Email + Contacts via the "Google Setup" and Calendar via "ActiveSync"

WHY bother with this and not use ActiveSync for emails also? This is because there is this huge bug with ActiveSync and Google for mail. If you have a subject line that is >60 characters and you try to reply to the email, the message gets jumbled/corrupted/unreadable

See this Link

I hope this helps people to fix things for some

  • The above description is accurate and works! In case you still have troubles after following the above description, try adjusting point 7. by giving domain as "google" and server as "m.google.com", as described at email.about.com/od/accessinggmail/f/… – f055 Nov 11 '13 at 16:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.