1

I turned on the bluetooth on the phone and the headset, but it was not located by the mobile phone. I´ve tried several times, even turning it all off and on again, but without success. Please let me know if you know how to, or if it´s a known problem. Thanks a lot in advance!

2

You have to put the headset in the pairing mode, to do that follow the following steps:

  1. Make sure that your headset is powered off.
  2. Press and hold the power button for 5 or 6 seconds until the light starts flashing an alternating red-blue.

Once the headset is in the pairing mode, start the pairing from the phone and things should work and you'll be able to find the headset.

  • Hi HaLaBi, tks, but it is exactly what I am doing. It doesn´t pair. I am wondering if it is not compatible with Plantronics... – laura Oct 2 '13 at 22:45
  • @laura AFAIK Bluetooth headsets are following some standards which are compatible with all phones. Anyway, I am pretty sure this headset works with lumia 620. – user1977 Oct 2 '13 at 22:49
  • @laura are you sure the lights were blinking? and did you test the headset on another phone? – user1977 Oct 2 '13 at 22:52
  • Yes, it is blinking. I tested the headset with my PC (today), and some months before with an Android Phone and it worked properly. Now, I noticed that the Lumia was running under "economode" (low battery), and decided to recharge it, turn the phone off (completely, not just the Bluetooth feature), and.. voilà! It paired, and is fuctioning. – laura Oct 2 '13 at 23:18
  • 1
    Thank you all a lot for the quick responses and willingness to help! – laura Oct 2 '13 at 23:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.