9

I use Google Contacts and Calendars with my Lumia 920 (GDR2/Amber update) since beginning of 2013, so I'm one of the users, who access contacts and calendars still via Exchange Active Sync. I've always used two Google calendars, my main calendar and one with the birthdays of my contacts.

Since a couple of days my main calendar isn't shown anymore. It's available in the settings view, so I can enable or disable the calendar, but no appointments are shown. I've tried enabling and disabling the calendars, syncing, etc. but nothing helps.

I had this issue when I got my phone one year ago, but after a couple of syncs it worked.

  • Is your Lumia running the GDR2/Amber update? – Neil Turner Nov 25 '13 at 12:26
  • Yes, forgot to mention. – Simon Nov 25 '13 at 13:00
16

During 2013 the behaviour of Google accounts using ActiveSync/Exchange has changed - some shared and additional calendars disappear.


Accounts

The GDR2/Amber update for Windows Phone 8 adds support for CardDAV and CalDAV which should fix this issue. To verify it's working...

  1. Go to Settings > Email+Accounts
  2. Tap on your Google account to see its settings
  3. Scroll down to the end and look for CardDAV and CalDAV

If you don't see settings for CardDAV or CalDAV, remove that Google account and add it again. This will ensure CardDAV and CalDAV are used.


Sync Settings

Next, you'll need to confirm which calendars are set to sync...

https://www.google.com/calendar/syncselect

I followed the above on my Lumia 820 running GDR2, I have a few calendars and several shared calendars and they all show up in the Calendar app.

  • Works, thanks! MS could have mentioned that in the release notes. – Simon Nov 29 '13 at 20:48
  • You're welcome - and I agree ;-) – Neil Turner Nov 29 '13 at 23:11
  • Great answer! The Sync Select link actually saved my butt. Any idea, why all calendars are not checked as synced (and thus does not show up in Lumia), when they're all available, synced and visible in on-line version of Google Calendar? – trejder Jan 11 '15 at 22:00
  • 1
    @trejder I can only guess, but I think only your primary calendars are initially selected, shared calendars are not. – Neil Turner Jan 12 '15 at 17:07
  • 1
    @Zavael it was mentioned in their help docs a couple of years ago – Neil Turner Mar 12 '15 at 14:01

protected by Indrek Nov 21 '14 at 5:05

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.