1

I have battery saver turned OFF, and in email settings as items arrive.

Sometimes I receive email immediately and sometimes I have to sync it manually. I have excellent signal and it happens either with 3g or 2g network settings (wifi is turned off).

What else should I check to receive push emails? I don't see an option to put mail into background tasks?

UPDATE:

It works as expected over wifi, emails are pushed as they arrive. So what is wrong with 2/3g?

  • In the "email+accounts" it shows like it was not sincronized? – Vitor Canova Jan 13 '14 at 14:14
  • @VitorCanova in email+accounts is list of accounts, what exactly am I looking for here? – mpapec Jan 13 '14 at 14:18
  • If there is a sincronization problem it will show just below the account name with your accent color. – Vitor Canova Jan 13 '14 at 14:26
  • Forgot to say but I have some situations where I don't receive the pussh immediatelly. But I did receive in some minutes. It says it is sincronized though. – Vitor Canova Jan 13 '14 at 14:28
  • @VitorCanova no sync error there, I have to do it manually (10 or 15 min after mail arrival). – mpapec Jan 13 '14 at 14:30
1

Problem was with APN setting given by provider.

As it seems push mail does not work with proxy server and should be removed in order to enable active sync. Also as a side effect, mobile net feels more responsive.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.