3

In early 2014 I installed "Update 3" (8.0.10517.150) and the "Lumia Black" software update via AT&T. After the update, everything worked fine EXCEPT MMS (the ability to send and receive pictures/videos/media through the messaging app).

When attempting to send an MMS message you receive the error:

"Can't send message Try again"

When attempting to receive an MMS message you see:

"Get media content now"

Clicking either of those links does not resolve the issue.

  • Are you sure that the problem is not with your operator? – N K Feb 4 '14 at 5:45
  • Yes. Wasted an hour on phone with AT&T support and they confirmed their side looked good. They blamed software and transferred me to Nokia support line, which was closed. Gave up on that approach and found the answer, as posted below, which fixed it. Does appear to be a software issue in this case (keeping in mind MMS was working just fine on the carrier right before the software update). – Kerry Feb 5 '14 at 16:54
3

This fixed it for me:

  • Tap Settings
  • Tap access point
  • You may see an access point for your carrier like "AT&T" listed as "active". This is the one that is not working with MMS.
  • Tap the + icon at bottom to add a new fake access point.
  • In the "Name" section, under "Connection name", enter any name like "fake".
  • In the "Internet APN" section, under "Access Point Name", enter any name like "fake apn".
  • The checkmark icon at the bottom should now be available for you to tap it so you can save this fake profile, tap it.
  • Back in the access point list, tap the fake access point you just created to switch to it. Wait until it says that it is active.
  • Tap the back button.
  • Go back into access point menu and notice that your "AT&T" (or your carrier) access point is there, but it listed as "inactive" now.
  • Tap on it to make it active again and wait for it to say "active".
  • Send an MMS picture message, your MMS should be working again.

Thanks to the person who posted the solution that I found here: http://discussions.nokia.com/t5/Nokia-Lumia/nokia-lumia-920-access-point-is-missing-from-setting/m-p/1648360

  • Perfect solution!! I had been having the same issue though I didn't realise it was after the Lumia Black update. Had tried every combination of turning data off/on, resetting phone etc but this solution has given me back picture functionality withing text messages and MMS - Thank You – user5308 Mar 17 '14 at 2:49
  • Thank you so much!! I kept trying to nu-activate it since there were other access points, but they did not work. Thanks so much. – user5319 Mar 17 '14 at 16:15
  • This is crazy, but I'm still using W10 phone (love it!) and had this issue after the last security update. My mms messaging started working again after restarting the phone. – blaylockbk Mar 24 at 19:50

protected by Community Mar 18 '14 at 1:07

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.