6

Yesterday I bought Lumia 520 with Windows Phone 8. All is fine, but gmail - it won't connect to gmail, synchronize anything (mails, contacts). All it does is asks me for username and password, which I provide, then tries to synchronize and finally asks me for password again.

I've tried setting it up both as gmail account and as Sync/Exchange account, to no avail. I'm confident I'm providing it with good credentials.

I looked at m.google.com/sync but it does not help at all - it shows link on how to sync using Windows Phone but there's nothing there.

System is updated to latest version - this did not help at all. Also - I'm trying to do this while connected to WiFi network or cellular one with no difference.
Other accounts, like twitter or facebook, connected quickly and with no issues at all.

Any idea on what's going on here? I've been looking at some other answers but nothing helped.

  • Have you used Gmail on another phone before? is IMAP access enabled in Gmail settings? – Neil Turner Feb 13 '14 at 21:34
  • Try looking at some of the suggestions here: neowin.net/news/how-to-use-google-services-in-windows-phone-8 – Wayne In Yak Feb 13 '14 at 22:56
  • Haven't used GMail on other phone, but did sync with it using outlook few times - worked perfectly. POP3 and IMAP turned on in Gmail settings. – Jarek Feb 14 '14 at 15:43
  • @WayneInYak - have already tried those, with no effect – Jarek Feb 14 '14 at 15:45
3

Make sure you did not enable security notification feature via sms verification code if you access your account from unrecognized devices for your google account. If you log in from a new computer to your gmail account and you have enabled this feature, google will ask you to enter a verification code that they has just sent it to your mobile phone via sms. You can disable this feature from: Google Security Settings

Go to

Password

section and choose Settings after

2-step verification option

you will see a box on the right of your screen contains data similar to this one:

2-Step Verification is: ON Protecting your account since Aug 4, 2013.

Press on the Turn off Button. You will be asked to confirm that you want to turn off verification codes click on Turn off

Delete your google account from your Windows Phone and Add it again.

  • Ihad 2 step verification enabled, But solution was to generate verification password and not to disable 22 step verification. Thanks for help though! – Jarek Feb 16 '14 at 10:56
  • You are welcome anytime:) – Mohammed Hassan Feb 21 '14 at 0:18
  • This answer is making the OP turn off 2-step auth. This is a bad move. I use 2-step auth just fine and I used the same process as heart333 specified below. I had no problems for about 1 year since I use this like that. – Timotei Aug 27 '14 at 18:18
5
  1. Do you have 2-step verification enabled? if no, then I probably won't be able to help if yes, go to step 2.
  2. Go to your privacy page on your Gmail account and look around until you find a link showing you the one-use passwords.
  3. Name the password Nokia Lumia Mail and type in the password provided into your password box. It SHOULD work.

P.S. I recommend setting up the passwords on a computer.

protected by Vitor Canova Apr 8 '15 at 16:31

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.