7

Background

I used to have numeric lock screen password. The virtual keyboard was the numeric phone dialing keyboard with big keys. All was peachy, I could keep the phone to lock in 30 seconds because entering the code was so fast, and I could do it without looking even on the virtual keyboard.

Then I got pushed a new policy from Exchange, which required a more complex password to unlock the phone. At the same time, lock screen password entry started to use the full QWERTY keyboard. This was all very annoying, but I had to change the code just to be able to use the phone again. Such is the life of a corporate peon.

Luckily, the policy change was an accident, and got reverted, and I could change my password back to the old numeric code. Only one issue: the keyboard still is in QWERTY mode! This is a major PITA and forces me to have longer lock timeout than I'm comfortable with, just to keep my sanity.

Questions

How can I change the lock screen password entry back, to use the numeric phone dialing keyboard?

I hope there is some other way than resetting the whole phone! But if there isn't, I'd like confirmation that resetting the phone does indeed fix this. Does anybody know this for sure?

6

Ok, solution was really quite simple, this may be enough:

  1. Disable lock screen password
  2. Enable the lock screen password. When it prompts for the new password, it should show just the numeric phone dial keypad.

Makes sense in the hindsight, though I tried other things before I figured it out. Just in case, here's a list of steps I did. Again, the bolded steps are quite possibly enough.

  1. Change password to numeric
  2. Reboot
  3. Remove the Exchange account from the phone
  4. Reboot
  5. Disable the lock screen password
  6. Reboot
  7. Enable the lock screen password, problem finally fixed
  8. Add the Exchange account back (which fortunately is just re-typing the email and password for it and reviewing synchronization settings, not a big deal).
  • 1
    This worked on android too :) what an answer mate :) – user22346 Jul 27 '16 at 11:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.