3

On May 11, 2014 (which was Mother's Day) my Lock Screen was saying that "tomorrow" would be Mother's Day. Then, on May 12 it said "today" was Mother's Day. However, when I checked my Calendar, I could clearly see that Mother's Day was May 11.

Lock Screen shows Mother's Day as Monday May 12Calendar says Mother's Day is on May 11

What's going on here? How do I fix it, and prevent it from affecting other calendar events?

Some notes about the phone and its configuration:

Make/Model: Nokia Lumia 920
OS Version: 8.10.12359.845
Date+Time Setting: 24-hour clock, set automatically, (UTC-05:00) Eastern Time (US & Canada)
Lock Screen "Choose an app to show detailed status": Calendar
Region: United States, English (United States)
Calendar is allowed to run in the background, but not when Battery Saver is on.

UPDATE

I tried [RIPS10's suggestion]. The reboot didn't help, but resetting the detailed item on the lock screen worked for Mother's Day. However, the problem has resurfaced today.

This doesn't just affect holidays - it appears to (at least) affect any all-day activity. I have a recurring Calendar item I set up myself for Patch Tuesdays, and on May 13 it's telling me that Patch Tuesday is "tomorrow".

Lock Screen says Patch Tuesday is "Tomorrow" from May 13Calendar shows Patch Tuesday is on May 13

  • 3
    What time zone is your phone running in? – Rowland Shaw May 12 '14 at 16:35
  • @RowlandShaw U.S. Eastern. However, I'm not sure that really matters. In the Lock Screen screenshot you can see the phone knows today is May 12, while in the Calendar view Mother's Day is shown on May 11. The Calendar view also shows May 12 ticked as the current date. – Iszi May 12 '14 at 16:37
  • What region is your phone set to? – karancan May 12 '14 at 17:58
  • @karancan See update – Iszi May 12 '14 at 19:05
  • It might be the case that the all day event is all day for a different timezone, and that was confusing it. It might also be a bug that could be reported to Microsoft. – Rowland Shaw May 13 '14 at 8:03
1

I think the issue is with the Settings for Date+Time.

Try this

  1. Settings > Date+time
  2. Change Set Automatically to Off
  3. Time zone > select coordinated Universal Time (UTC)
  4. Adjust the time to match the current time in their location
0

Try to restart the phone first. If that doesn't solve the problem choose another app to show a detailed status. Refresh your lock screen by locking your phone. After that choose Calander again to show detailed status.

  • Reboot didn't work, but resetting the detailed status item did. How do I prevent this from happening again? – Iszi May 12 '14 at 19:05
  • More people got this problem, just a bug in the developer preview. Don't know what the actual problem is or how often people got this. – RIPS10 May 12 '14 at 20:57
  • Can you provide links to other reports you're seeing? – Iszi May 13 '14 at 14:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.