When I click delete on an email (gmail) in Windows phone, not only does it not archive the email (which is what I'd prefer) but it doesn't even delete it when I go check my email back in gmail website. All it does is hide it inside the phone but it's not really deleted or archived in the account.

  • 2
    Have you waited until he next email sync? Or synced it yourself? The phone won't auto push changes to the server. Instead it does it on intervals
    – user131
    May 8, 2012 at 1:49

2 Answers 2


After some hours of research I finally found the solution. Through your browser (on Windows Phone) go to http://m.google.com/sync, login with your data and select WP7 device. Now you only need to enable the option: Enable "Delete Email As Trash" for this device. Save and exit.

Now if you delete an email from Windows Phone, this email went correctly deleted in Gmail.

  • 5
    I believe this does no longer work due to changes to the linked website, as of 2012/12/28
    – kontur
    Dec 28, 2012 at 12:43
  • 1
    What is the best approach at this moment (2013) Sep 30, 2013 at 9:58
  • The correct approach at this moment (2016) is to use below (jimueler's) answer. And the correct answer is -- you don't have to do anything! As long as you have default (presented on screenshot) settings set in Forwarding and POP/IMAP all your deleted in Windows Phone message will be archived actually. See Google Help for details.
    – trejder
    Jan 7, 2016 at 20:57

By default, Gmail deletes (moves to the Bin folder) only messages deleted inside Gmail itself or in Gmail program for Android system, that is mail clients that operate directly on Gmail's mailboxes.

Message marked as deleted in any other mail client (which syncs messages with Gmail via IMAP) will be archived by default (moved to the All Mail folder).

Take a look at following screenshot:

Gmail IMAP Settings

This is the default setting, so if you haven't changed it, when you delete a message in Windows Phone (or any other device that uses IMAP to sync folders to Gmail), it will be archived, not deleted.

I have confirmed this by deleting one message from my mailbox in Windows Phone and moving a second one to the [Gmail]/All Mail folder (this operation is equivalent to archiving). Both emails were placed in the [Gmail]/All Mail folder in Gmail, i.e. both were correctly archived.

You can read more about Deleting IMAP messages on Google's support site. To cite Google (emphasis mine):

If you delete a message from your inbox or one of your custom folders in your IMAP client, it will still appear in [Gmail]/All Mail.

Only if you change the above configuration to "Auto-Expunge off" + "Move the message to the Trash" you will achieve the result that deleting mail in an external mail client will result in actually deleting it.

  • In the past, this did work, but currently I think the only way is going with @enigma answer (that's what I currently do!) May 9, 2012 at 17:07
  • And I'm not sure how it ever worked in most cases - Gmail sync with Windows Phone uses Exchange ActiveSync by default, not IMAP. May 11, 2012 at 2:19
  • @MichaelRatanapintha I agree, I saw the setting and figured it explained the behavior. Since GMail can push to Windows Phone, it must be using ActiveSync, not IMAP. enigma probably has the best answer.
    – jmmr
    May 11, 2012 at 4:05
  • 1
    I have entirely reedited above answer and I'm waiting for it to be peer reviewed. I completely don't understand, why most of you (including answer's author) claim that enigma's answer is better. Currently (begin of 2016) it is exactly opposite. Enigma's answer is obsolete and no longer working (given link redirects to some info page, no settings) while this answer is perfectly correct -- you don't have to do anything. As long as you have default (presented on screenshot) settings set in Forwarding and POP/IMAP all your deleted in Windows Phone message will be archived actually.
    – trejder
    Jan 7, 2016 at 20:55
  • 1
    @trejder At the time of this post in 2012, Gmail was primarily sync'd to Windows Phones with the Exchange Active Sync (EAS) protocol, which enabled push, etc. That is why I edited and said the other answer was better, because we were talking about EAS, but my answer was about IMAP, so I doubted it had an effect. Now, things are totally different since Google removed EAS and we now connect via IMAP. I think your edits are fine and reflect the current state.
    – jmmr
    Jan 16, 2016 at 4:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.