0

I am a new user, and on one of the questions I saw that many are facing a problem about the toast notifications of apps in Windows Phone 8. Seems like the issue has been sorted out in Windows Phone 8.1, but no relief to users of Windows Phone 8.

A temporary fix is to turn ON the Battery Saver feature in Settings.

  • 1
    Please note that this is a Q&A site. While it's OK to answer your own question, your post should contain an actual question or problem, and the solution should be posted separately as an answer. – Indrek May 30 '14 at 10:52
4

For some apps, you can turn off notifications through the app's own settings.

For the ones that don't allow this, do the following:

  1. Go to Settings
  2. Swipe right and choose "background tasks"
  3. For each app that you don't want to receive notifications from, block it from running in the background. This will take effect once you exit the application.

For games, swipe right in Settings and choose Games, then disable the "Sync game requests" and "Show game notifications" options.

| improve this answer | |
1

You're right. This isn't possible in Windows Phone 8, aside from on a per-app basis.

Good news though, it is possible in Windows Phone 8.1 which will be available for the public fairly soon.

On Windows Phone 8.1 go to Settings > Notifications + Actions > then click on the app you want to adjust notifications for.

(This feature was added along with the notification center in 8.1.)

enter image description here enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.