5

I have a Nokia Lumia 710 which came with windows phone OS 7.5. The problem I've got is, by using the default IE browser that came up with the phone, I can not browse the sites that have popup Windows (Basically it doesn't show popup windows).

In settings I didn't find any option to allow popups and in some POSTS, I found that IE on Windows Phone 7 does not support pop up windows.

I tried downloading some other browser apps, but none of them work. But does anyone know any free application to download from the Windows marketplace or any other way that will allow me to browse the web sites that have popup windows using my Nokia Phone which has windows phone 7.5 OS. Thanks in Advance....!!!!

  • 2
    i thought it open in new tab. But never tried. – Vitor Canova May 9 '12 at 11:56
  • HI, Vitor Canova...The problem is, it doesn't open in any way(Either in a new tab or as a seperate Popup window). Therefore Don't have any way to view the content(popup window). – JibW May 9 '12 at 13:35
  • 2
    Can you share the URL? I'm having problems finding a site with a popup! – user131 May 9 '12 at 15:39
  • Hi Joe, Its actually a login Screen... When I provide correct credentials only, the next screen appear as a pop up window. :(. Here in this case nothing happens even when I provide correct username/password since pop up windows not working in Windows phone IE browser(It works fine in my desktop and iphone browser with correct credentials). – JibW May 9 '12 at 16:18
  • 1
    I tried here. It open in the same tab. – Vitor Canova May 9 '12 at 19:41
4

Pop-ups are getting deprecated and when someone chooses to implement it in their site they are simply shooting themselves in their own foot for not being Browser and Device Independent; really, W3 discourages it and provides alternatives. Thus, don't expect these on a mobile browser.

It's the developer that has to adjust; not you, the user that has to figure ways around standards. At best you could figure out the URL that is being opened in the pop-up on a computer, and open that URL on your mobile phone. But other than that, the site you're browsing is outdated and isn't made to support the mobile world...

  • HI Tom Wijsman, Thanks for the response. But my friend has an Iphone and he can see the popup windows in his default browser(Safari) within the phone. That's why I am looking to do this even by using a 3rd party web browser App(From Windows Market place) atleast... – JibW May 9 '12 at 14:48
  • This answer is not helpful. – Christopher Scott Nov 19 '13 at 23:04
  • 1
    You'll not find anything more helpful on Windows Phone itself because this is simply how it currently works; the only way you might be able to achieve more useful behavior yourself is to write a proxy that specially handles pop ups in a way that they become more easily accessible, but writing such thing is very likely an overkill task that takes time to implement. Speaking up your needs as a customer is really the simplest way; unless well, you find someone that implements a crazy proxy or you manage to convince Microsoft to support it. Out of these options, the choice is easily made... :-) – Tamara Wijsman Nov 20 '13 at 1:27
1

I also have a windows phone, Nokia 900 with 7.5 on it. After many hours with Nokia, Microsoft, and the phone company we determined that the windows phones will not let you allow popups. My company has a Sonicwall router that makes you login before you can use the wifi. This makes the widows phones useless for a business type operation. I have also asked if the 920 will be the same and they said yes. Microsoft has to fix this problem if they want business to use their os on the phones. It is not just one brand of phone it is a windows issue.

  • Sounds like your issue is as much with sonicwall as the browser... – Rowland Shaw May 2 '13 at 18:36
  • @user1331 Have you tried to copy that login page and access it directly in the browser? It is an internet address, it need to be accessed directly. – Vitor Canova Jun 30 '13 at 12:59
  • The only way I can login into the SONICWALL authentication system is by saving a bookmark with the address that was contained in the pop-up window and then launching it manually after I enter the credentials. Check this source for clarity: genobz.com/2014/login-sonicwall-internet-using-windows-phone-8 – user4887 Feb 8 '14 at 21:14
1

My university has Dell/Sonicwall Firewall installed which necessitates opening of a pop-up window to initiate internet access.

I resolved this by saving the URL of the pop-up window (when it opened on my laptop), and saving it as a bookmark on my phone. Now, upon initiating the login process, I am notified that the pop-up window couldn't be opened. I click on OK and then launch my saved bookmark. This grants internet access to my phone.

You may find a video tutorial here.

0

There is a solution for your problem with Windows Phone, but it involves the SonicWall administrator. In SonicWall management go to Users -> Settings -> clear the option "Show user login status window". Now every smartphone (including windows phone) will be able to authenticate and use internet without the need to enable popups.

Hope this answer helps you.

-1

You can unblock pop ups. The link below contains instructions how. http://stickytricks.blogspot.in/2013/11/unblock-popups-in-windows-phone.html

As follow:

1- Try to log in your account as you were trying earlier.

2- A popup will occur that shows a message To Disable Popup Blocker

3- Select OK.

4- Copy the address from the address bar in the popup window,, this you can either from your computer or any other popup enabled device. Log in to the account from any above mentioned device (either computer or popup enabled device)

5- Enter the address in your windows phone and click on GO button.

As you click, a popup will occur again and will ask to open this window as popup, click OK button. Now you will be access to the service

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.