4

I have Gmail syncing to my Lumia 1020. Before Windows Phone 8.1, I could sort of delete e-mail by hitting the delete key. It would go to a Deleted Items folder, which I then had to delete in the Gmail web client, but at least it was all in one place.

After the 8.1 update, I can't even do that. Deleted e-mail gets archived instead.

What settings can I use to get my e-mail to actually delete from Gmail when I delete it in my Lumia 1020?

1

Since 8.1, Gmail is no longer a "special" type of account, so a delete performs whatever action you've got configured with GMail -> Settings -> Forwarding and POP/IMAP, and you have the following options:

When a message is marked as deleted and expunged from the last visible IMAP folder:

  • Archive the message (default)
  • Move the message to the Bin
  • Immediately delete the message forever
  • 2
    Well, currently mine is set to "Move the message to the Bin", but when I mark it as trash on my Lumia, Gmail archives it instead. – Kyralessa Aug 11 '14 at 12:36
1

1) go into settings / forwarding and pop/imap 2) turn auto-expunge off (so that you can change the settings for the next group down) 3) change the setting below to "immediately delete the message forever" 4) save changes

Did a single, simple test and it seemed to move the message to GMail's trash folder. Took the time to figure this out after spending ten minutes manually deleting crap from the archive (that I thought I had deleted via my phone).

UPDATE: Checked it again from home and the stupid thing still is archiving the mail I delete from phone. Anyone else have a good way to do this?

  • I tried it: Auto-expunge off, immediately delete. It still archives. :( – Kyralessa Oct 17 '14 at 0:21
0

Try selecting mail item and then go to move and then to garbage. Now go to your garbage and empty it and be sure to refresh after.

  • This works...but it's annoying to go menu up, move, tap on folder, when there's a trash can right there. And the trash can used to work at least a little better than this; it would move things to Deleted Items, whence I could delete them. – Kyralessa Oct 17 '14 at 0:23
0

Try going to the below link from your phone and make sure things are setup correctly.

https://m.google.com/sync/settings/

I've had to do this a couple of times to get emails to go to the trash instead of archive when deleted from my phone

  • All it lists there is a couple of things called "WindowsMail", with a last sync of 3/29/2013 and 9/6/2013. I think those probably refer to Windows 8/8.1, not my phone. My phone isn't listed there, as far as I can see. – Kyralessa Oct 10 '14 at 23:09
  • I believe that's the old Exchange ActiveSync list that isn't supported any more for new devices – David Gardiner Nov 24 '14 at 1:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.