9

My Gmail messages don't sync immediately to the server after they are read/deleted/modified on the phone. You need to wait for the next sync cycle or press the sync button to manually sync it.

I am so used to this happening on my iPhone that I have taken it for granted. Now its a big nuisance. I read emails on the phone... come back to my desk.. and its still there... unread!

I would have thought this to be very obvious flaw the designers would have caught. Even android phones sync immediately.

Is there a way to make this happen?

PS: Changing the sync setting to as items arrive does not help.

  • Hey Bobby, do you know if this problem still persists in WP8.1? – Vitor Canova Jul 8 '14 at 15:38
  • @VitorCanova: I no longer use a Windows Phone. The list of limitations kept getting longer and longer and I sold the phone after months. Moved to Android; never had a reason to look back. – bobbyalex Jul 8 '14 at 15:45
6

Tapping the sync (refresh) icon in the Email app should force all items to sync.

  • Ditto, although one of the few behaviours I miss from the iPhone is it automatically doing a refresh when you open email. – Jesse Apr 25 '12 at 6:35
  • 1
    Yes. I know about the sync button (mentioned it in my question too). I wanted to know whether the sync can happen automatically. Seems dumb that you have to do it manually every time. – bobbyalex Apr 25 '12 at 9:20
  • Would be nice if it wasn't necessary to manually sync, though :) – Derek Lakin Apr 25 '12 at 9:30
  • @All Really? How can there not be a way to automatically sync? Please update this thread with an answer in case anyone finds out a way – prrao Apr 25 '12 at 15:46
1

I came across this suggestion on another board:

Gmail actually can use Activesync which is similar to the Exchange server. The absolute best way to set up your gmail account and enable true push is to go to email & accounts>add an account and choose the "Outlook" option instead of "Google". type in the full name and password, click sign in. For username type your full email address, then under domain type "m.google.com" and continue. It'll tell you it can't find settings, click "advanced". For server type "m.google.com". This will set it up to automatically sync email, contacts and calendars. Your emails should also arrive much more quickly.

Note, I haven't tried it myself, since I'm happy with a 30 min lag, but it might solve your problems!

0

Yes, you are right. The emails read/modified/deleted on the phone do not sync back immediately to the server even after the synchronization is set to 'as items arrive'.

You've also already listed that the way to workaround this and get changes made on the phone to reflect on the server is:

1) Wait for a synchronization cycle.

2) Run a manual synchronization.

To add to your observations, I've also seen that if you have 'as items arrive' set, then receiving a new e-mail after the older ones have been read/modified/deleted on the phone forces the changes made to the older e-mails on the phone, to reflect on the server.

Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.