2

I use Nextgen Reader on my Windows 8.1 Pro (Update 1) desktop and on my Windows Phone 8.1 (release 8.10.12393.890) Lumia 620 phone.

I bought the App today from the desktop. If I check on the store I see the App as installed:

screenshot from the Windows Store

If I check on windowsphone.com I see the App as already owned:

screenshot from the web

But if I check the App on the phone I still can press the button buy:

screenshot from the phone

Usually when I buy an App the buy button is changed in the share button:

screenshot from the phone (Metrotube)

The App is an universal app, so it should follow the rule: buy once and run on multiple devices (Windows or Windows Phone).

I don't want to try to press the buy button on the phone because I don't want to risk to be charged twice for the same App and have to ask assistance for a refund.

Can someone please explain me if this behavior is normal? Thanks in advance.

  • Have you tried the reinstall button, from the website version of the store? – Rowland Shaw Oct 13 '14 at 16:19
  • Thank you, it worked! Please, convert your comment in an aswer, I would accept it gladly. – Manuel Durando Oct 13 '14 at 22:22
2

Your phone is showing [ buy ] only because the licence hasn't been synchronised with the phone - you've got two options:

  1. Pressing [ buy ] will synchronise the licence, and install the app without incurring additional charge.

  2. Using the web store to push the install to your phone

2

You still see the buy button as you don't have the app installed on your phone yet. When you hit buy the phone will check the store if you have already paid for the (universal) app and then let you download it. Afterwards you'll see the share button.

  • I already have the App on my phone, I used for it a while in trial mode. Does the rest of your answer remain valid? Thanks. – Manuel Durando Oct 13 '14 at 21:46
  • Ah, I see. Yes, when you try to buy the app, you should just see a confirmation that you already paid for it and the full version will be unlocked. – Thomas Oct 14 '14 at 0:54
  • I already solved the problem by following the suggestion in the @Roland Shaw's comment, but thanks anyway. – Manuel Durando Oct 14 '14 at 6:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.