1

I'm pretty sure I used to be able to send links and things via Twitter, whenever I the OS-provided "Share" functionality such as is available via "share page" in Internet Explorer. However, and I'm not sure when this changed, it appears to no longer be an option.

I've checked email+accounts, and my Twitter account appears to be properly configured there. When I force a sync, there are no errors.

When I first noticed this issue, I thought it might be because I didn't have an "official" Twitter app installed. Since the latest reformat of the device, I'd only installed MeTweets as a Twitter client. I tried to fix it by installing the official Twitter app but that didn't change anything.

Some information about my phone:

Make/Model: Nokia Lumia 920 (rev. 6.0.0.1)
Firmware: Cyan (rev. 3051.50009.1425.2001)
OS: Windows Phone 8.1 (rev. 8.10.12393.890)

The phone went through the normal update processes for Amber and Black. When 8.1 Developer Preview came out, I ran with that. Shortly after Cyan came out, I used the Nokia Software Recovery Tool to wipe the system and install Cyan/8.1.

So, this breaks down to a few questions:

  1. Is sharing via Twitter now, or was it ever, actually available using "Share" functions built-in to the OS since 8.0?
  2. If no longer available, when did that change? (Bonus: Why?)
  3. If still available, what settings do I need to check to troubleshoot why I cannot see this option?
1

What you are referring to by "share" is ShareLinkTask, Now for your queries:

  1. Yes, sharing via ShareLinkTask is available both on Windows Phone 8 and 8.1. But Twitter changed their oAuth service on platform 8.1 and for that sharing is not possible in 8.1. Putting it simple: same share codes work in WP8, but not in 8.1.
  2. Told you, they changed their authentications, that's why not possibe in 8.1.
  3. There is nothing you can do right now, #MSFT is trying to figure out this matter already.
1

Sharing via Twitter was an option in WP8, I'm sure because I used it.

I checked on my Lumia 620 with WP8.1 with two different Apps and you are right: the share menu doesn't offer anymore Twitter sharing option. Same like you, I have my Twitter account correctly configured.

I had a look around on the web and I found this article that says:

The app works quite well on 8.1, but the ability to Share to the app has disappeared and it doesn’t fully leverage the capabilities of the 8.1 operating system.

So there isn't nothing you can do to get it back, we have to wait for a Twitter update of the App (which are so frequent btw).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.