1

I have a Nokia Lumia 520 OS version 8.10.12393.890 Firmware 3058.50000.1425.0004

I have setup an outlook account for syncing with this phone. If I enter a new contact in outlook contacts (in my webbrowser) with an US telephone number, I see something weird.

When I enter e.g. the Microsoft telephone number on the web as +18006427676, In the telephone I see this appearing as +1 (800) 642-7676 The latter does not work for sending SMS because of the formatting.

How can I disable this autoformatting of US numbers?

EDIT:

I also tried the same thing with dutch and thai phone numbers (+31 and +66). Those numbers will not get formatted in the phone.

  • 1
    What error do you see if you try to send an SMS to it? – Rowland Shaw Nov 25 '14 at 20:32
  • In the message I see something like "Unable to send, try again" (sorry the exact message is deleted). I have tried to change regional settings, but it does not make a difference. – bart s Nov 25 '14 at 20:44
  • 1
    Well, I have a UK phone, it'll happy send to numbers that are "pretty printed", including to UK landlines. It's unclear if you're trying to send to land or mobile lines, but it may be that your operator is either out of range, or denying for "some reason" – Rowland Shaw Nov 25 '14 at 21:12
  • @RowlandShaw I am in the Netherlands and I think it is completely stupid to have a phone decide for you that US numbers will get formatted with () and - while all other phone numbers will not get formatted. (need to say I did not try UK numbers) – bart s Nov 26 '14 at 6:27
  • Are you using a Dutch SIM card? And what region is your Microsoft Account tied to (it should show at account.live.com/SummaryPage) – Rowland Shaw Nov 26 '14 at 8:36
1

On your Windows Phone, inside the phone app go to the settings menu and disable "International assist".

  • I will try that and feedback if it makes any difference (currently not have the phone with me) – bart s Nov 26 '14 at 6:25
  • This setting is disabled already, but the formatting for US numbers is still there. – bart s Nov 26 '14 at 19:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.