4

I updated my Lumia 520 yesterday to Windows 8.1, everything's cool, love the new features, I've checked I have all the alerts, volume and stuff properly set.

When I am using other apps, I don't get notifications from Whatsapp, nor when the phone is locked. If I want to check the new messages on whatsapp I have to open the app. It is not even showing the number of new messages at the tile.

I'm using Wifi, I'm not using Cellular data plan, what could be the problem? I already rebooted my phone several times :/

  • Have you allowed your phone to 'run application in background'..for that go to battery saver..select the app..and turn on the option to run in background. – Saravanan N Dec 5 '14 at 17:54
  • I went there, I see that WhatsApp says ALLOWED in gray below the usage bars :( – JuanBonnett Dec 5 '14 at 17:57
  • Can you turn on option to run in background when battery saver is on..too..then check(always allowed) – Saravanan N Dec 5 '14 at 18:01
  • It is set that way, Rebooted and still not working. Do you have also Windows Phone 8.1 and it is working for you? – JuanBonnett Dec 5 '14 at 18:15
  • Yes..its working for me.it may be work after reinstall the app.try it – Saravanan N Dec 5 '14 at 18:19
1

Ok, I've solved it. It's pretty simple.

Whatsapp (at least on Windows) gets confused when you have your CELLULAR DATA ON and your Wifi ON.

So... If you're at home using WiFi and you don't have an active Data Plan, turn it off! Yes, just go to Settings -> Cellular -SIM and turn it Off if you don't have an active Data Plan.

After that, Whatsapp is gonna get all the notifications from the WiFi network, not from a non existing Data plan ;D

Hope it helped

  • Not doubting the answer, I'm sure it worked...but this sounds weird simply because I have wifi and cellular data turned on most times, and I still get notifications. – Ankur Banerjee Jan 6 '15 at 1:57
  • You get notifications because you have an active data plan. I didn't have any data plan active. That might be the reason – JuanBonnett Jan 7 '15 at 11:51

protected by Community Dec 8 '14 at 12:17

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.