I'm trying to turn on internet sharing on my Nokia Lumia 925 and it starts running but after a couple of seconds it tells me that internet sharing is not working and all that. It has a password and the name for the network but it's not working.

Any ideas?

  • 3
    Is it possible that it's being blocked by your provider? – Thomas Dec 7 '14 at 9:34
  • Also, is your phone's software up to date, are you running Windows Phone 8.1 ? – Neil Turner Dec 9 '14 at 14:16

After typing in the password provided by Lumia about 50 times and every time getting told the password is incorrect I thougt of tapping the little pencil icon on the bottom of the screen. This took me to a page where I could change the password. I typed in a new password that I just made up. Problem solved!

Mine is a Lumia 735, I think.

When was the last time you updated your phone? I had the same issue when I did not update my phone for a long time(since 2017, December). When I updated Windows Phone OS to the latest version (2018, June), WiFi hotspot issues resolved.

Also, until my phone was updated, sometimes hot spot issue was fixed by the following steps

  1. I changed the SSID (hotspot name) and the password
  2. Disable/Enable the mobile internet

Sometimes it solved the problem, but most recently it did not.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.