4

Recently in Windows phone, my local calls have been automatically going to international number in the UK , i now can't make any local calls in my area, another area maybe ok, i have no idea what happened but this doesn't look like a carrier problem but a phone problem so, is there an option that i may have messed with in windows phone that take care of that?

  • Can you give a bit more detail, like what kind of numbers are being called? Also, is resetting your phone an option? – Neil Turner Dec 13 '14 at 21:27
  • i have resetted my phone a week ago because apps were crashing and photos were automatically deleted and many more problems, so i did reset my phone but now this new thing is happening, if i call a phone number in my area whether i call it from contacts list or just dial it it will dial a phone number beginning with +44 which is the code of the UK , if i call another number like another state say Michigan,then it's all good. – aero Dec 13 '14 at 23:24
  • 1
    Have you checked phone -> Settings if you have the "international calls" Option checked? Try unchecking that. – Thomas Dec 14 '14 at 11:44
  • Can you make sure any updates for you phone are installed, also check the region and language settings are correct? – Neil Turner Dec 14 '14 at 14:23
  • OK I just solved it, i changed language from English (UK) to English (US), thanks – aero Dec 17 '14 at 6:54
2

Things to check:

  • all phone updates installed
  • check the region and language settings
  • phone -> Settings -> "international calls" option enabled / disabled
  • i have installed updates, no option says (international calls) in settings, the strange thing is this only happens when i call my area code numbers.!! – aero Dec 17 '14 at 6:47
  • i did it by changing from English UK to US thanks – aero Dec 17 '14 at 6:58
1

A feature called International assist is responsible for your problem. Turn off the International assist in your phone.

To turn off International assist follow these steps :

  1. Open the Phone application.
  2. Tap the 3 dots (...) at the bottom right of the screen.
  3. Select Settings.
  4. Slide the International Assist toggle to either On or Off.

For further references see Microsoft FAQ on International Assist

0

Look at your contacts... If a + (plus sign) is in front.. Remove it. Transferring contacts sometimes goes wrong..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.