I'm consistently having an issue with trying to install the new Foursquare Windows Phone app from the app store (version The odd part is that this problem only happens with the Foursquare app. All other app upgrades and installs have been working fine for the past few weeks, except for this one.

I previously had the "old" design Foursquare app. When I got the notification to upgrade to the new design app, the app seems to download fine and then at the final step, it stops with an "Attention required" message. Clicking retry or cancelling the download doesn't make the error go away either. I uninstalled the Foursquare app (old school design), and tried to install it afresh from the app store, and that still didn't help.

I get an error code 80073cf9 (sometimes it's 80073cf6) which according to MSDN is an issue with app packaging / deployment (also see).

Other things I've tried to fix the problem, but which didn't try to work:

  • Soft reset my phone
  • Tried to sideload the app from my SD card (I get an error saying "Can't install company app: There's a problem with this company app. Contact your company's support person for help.")
  • Changed the app install location from "phone" to "SD card" (and back)
  • Wiped temporary files from both phone and SD card using Storage Sense
  • This happens too quickly for me to take a screenshot, but might be relevant: after the app is downloaded, the next step in the app store download status says "Restoring data", then briefly shows "Finalising" before it fails. I've deleted my phone settings+app backup before installing, and that didn't help either.

The closest that I have come to a similar problem is a Reddit thread mentioning a similar problem when the app publisher name changed from "Nokia" to "Here Europe B.V.". In Foursquare's case, it previously used to be "Foursquare Labs, Inc." and is now "FOURSQUARE LABS".

Finally, I also filed a bug report with Foursquare and got this response from them:

We've heard of this problem from a number of WP users, but unfortunately it is an issue with Microsoft. You'll need to reach out to them in order to fix it.

I wonder if there's any fix (other than a hard reset - which may or may not solve the problem) which I'm missing?

  • Perhaps related: 80073cf9 error while installing Whatsapp – Ankur Banerjee Jan 1 '15 at 0:50
  • Do you have Workplace set up on your phone? – RareNCool Jan 6 '15 at 14:27
  • Maybe you can delete your settings backup and after that try again (do the backup again after that). Other think you can try is change Region and try download from another one. – Vitor Canova Jan 7 '15 at 11:05
  • 1
    @VitorCanova I actually tried the backup thing as well! I deleted my backups, and then tried installing. I'm not sure whether Foursquare is one of the "participating" apps that backup their settings, but tried anyway. The region idea is a good point and I'll try that. – Ankur Banerjee Jan 7 '15 at 18:50
  • Have you tried a hard reset? – Thomas Jan 12 '15 at 12:55

I tried all of the steps highlighted in my question, and nothing worked. I didn't want to do a hard reset on my as that was my last resort.

I had further symptoms which the phone showed:

  • Problem was initially isolated to Foursquare only, but cropped up with the Lumia Cinemagraph app as well (another app that had been renamed from Lumia Cinemagraph Beta)
  • Under Settings > Backup, backups always failed if I had the App Backup option enabled. (I could only backup settings.) Deleting backups from OneDrive by going to Manage Backups didn't work.

In the end, I did have to do a hard reset. I had an OTA firmware push for Lumia Denim and I got an error 8007000d every single time I would try to upgrade. The download finished okay, but every time it failed after "preparing install". This error code is not one of the published error codes for upgrades with known resolutions.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.