6

My Nokia Lumia 520 running Windows Phone 8.1 Update produces a system alert sound whenever I complete a call (because I am on a pay as you go plan - the alert text indicates the cost of the call). The alert produces a sound that is the same as the sound named "Nokia message." Unchecking "System alerts" in Settings -> ringtones + sounds does not prevent the alert sound. Changing the sound set in Settings -> notifications + actions -> Phone has no effect on this particular message. I haven't been able to find what setting to use to change the sound played for these alerts.

How can I silence or change the alert (or message?) sound?

(The alert/message is not a text message - a record of it does not appear in the Messaging app.) (Carrier is Airvoice Wireless MVNO on AT&T network.)

  • You say the alert is from a text? If so, you should be able to add the sender to your contacts and assign it a custom text alert tone. – Indrek Jan 27 '15 at 17:46
  • @Indrek No, it is not a text message. It is a full screen message (like the phone equivalent of a windows MessageBox?). A record of it does not appear in the Messaging app. Changing the sound at Settings | notifications + actions | Phone has no effect on this alert/message. – sean e Jan 27 '15 at 17:58
  • 1
    Unless someone corrects me on this, I'm guessing that the message is being pushed by your carrier, so there's no way to change it. – RareNCool Jan 27 '15 at 18:10
  • @Drowin I don't doubt that the message is being pushed by the carrier but I don't think the sound is pushed by them with the message text. – sean e Jan 27 '15 at 18:12
  • 1
    @seane Whenever I get a message that isn't sent by the OS, the Nokia Message sound is the sound it makes. So I think that it is a preset sound that the OS uses when it doesn't know what the message is, specifically. Which would make sense, since it's a Nokia phone, and it's a message... (Nokia + message = Nokia message). Again, if someone knows differently, please correct me. – RareNCool Jan 27 '15 at 19:01
1

AFAIK, there's no way to turn off USSD tones.

0

Try if this will work:

  • Choose the Ringtones+Sounds option in your Settings
  • Scroll down to the bottom of the Ringtone+Sounds page until you find the “Manage App Sounds” button bar.
  • You will see options to choose your Quick Action button and just below is a listing of apps that support custom alert sounds.
  • Tap "Store"
  • Set Notification sound
    • None to be silent

Source

  • Nice try, but I already have Store set to None. :( – sean e Feb 10 '15 at 15:42

protected by Community Jul 30 '15 at 16:15

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.