0

I've just bought a Lumia 830 and it was unboxed with Denim Firmware update.

When I go to the Store to download the Lumia Camera 5.0 it does this succesfully.

Unfortunately when I try to start the app it says I don't have Denim Firmware Update installed.

What's happening?

  • I assume you've checked for updates? – RareNCool Mar 9 '15 at 18:44
  • Yes. Forgot to mention. I'm currently using Dev Preview so my phone is update as hell. ;) – Vitor Canova Mar 10 '15 at 11:50
  • Have you tried / could you try a soft reset? – RareNCool Mar 10 '15 at 13:22
  • @Shawn Didn't solve the problem too. – Vitor Canova Mar 10 '15 at 16:24
1

Try turning the Dev Preview off, reboot the phone and try again.

  • I just got done taking a 635 through a bunch of updates, and I can confirm the preview is not behind. – RareNCool Mar 10 '15 at 13:22
  • Ok I'll edit thx – boxa72_dev Mar 10 '15 at 13:23
  • Already done. Nothing changed. No updates pending, no startup of Lumia Camera too. – Vitor Canova Mar 10 '15 at 16:24
  • At no point is dev preview mentioned? – Rowland Shaw Mar 10 '15 at 21:17
  • @RowlandShaw Just edited my answer. boxa72 answer didn't help when I tried days before because the update was not available. But now it was available just because what he said. So I will upvote because it helped too. – Vitor Canova Mar 18 '15 at 16:07
1

I think I finally find out (but can't confirm myself at the moment).

Looks like Lumia 830 was released with a half baked Denim Firmware Update.

To be allowed to install Lumia Camera 5 on Lumia 830 it need to be updated at least to O.S. version 8.10.14226.359 currently unavailable even trough Dev Preview.

Source

Edit

Yesterday my phone finally receive an update as you can see below:

It said that the phone would update this:

  • Windows Phone 8.1 (8.10.14234.375)
  • Lumia Update for Windows Phone

Even though the version is above the one I report this update made my phone fully support the new Lumia Camera 5.

One more think: I needed to disable Dev Preview again to see the update, something that I've already tried with no success.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.