0

I have a Lumia 930 which is on Cyan. Whenever I check for updates, it gives this error:

We are currently unable to check for updates. (801881e4)

I've searched and the only solution provided in forums, ... is setting the correct date+time. I have set it correctly (switching off setting it automatically) and checked it again and again with no luck!

Does anyone know a solution to this annoying problem?

  • 1
    Are any other Microsoft services not working correctly (store, outlook)? – Thomas Apr 2 '15 at 9:55
  • @Thomas, outlook account syncs (after some retries). But store also gives error: we are currently unable to perform your request (or something like this) with error code: 80070020 – Mahm00d Apr 2 '15 at 10:46
  • This could acutally be a temporary issue with Microsoft services. Since when is this a problem for you? – Thomas Apr 2 '15 at 13:32
  • @Thomas, I doubt it. I checked with a Lumia 520 (previously updated to Denim) and both the update checking and app downloading works fine. I just bought this phone yesterday and it has the problem since the first boot... – Mahm00d Apr 2 '15 at 14:13
  • Have you gone to Settings > Email + Accounts and tried syncing the account, or making sure there are no errors with it? – RareNCool Apr 2 '15 at 14:33
0

OK. I was able to solve the problem. I thought I put it here so it may help others as well.

The issue was actually with the date+time and the outlook account, but not like the forums suggested:

The problem was that I had set up the account manually (from settings, not from when accessing store, ... asks to sign in) and set the date+time after the account was already set up.

So, here's how it was solved:

  1. I deleted the account from settings.
  2. I made sure date and time was correct.
  3. I opened the store and it asked for the account, so I sign it right there and ... voila! Everything was working!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.