0

Recently my Lumia 920 will not allow any wifi connections. I haven't changed any settings or did anything different with the phone, but when I try to connect it says "Your phone can not connect to the Wifi Network, try again later". I've turned the phone/wifi on and off several times and still nothing. What can I do?

  • Is the network working? is it “all Wi-Fi”? or just the one network? Try restarting the Wi-Fi hotspot too. – Aeyoun Jun 25 '15 at 10:26
  • Reset your router once and try connecting again... – vembutech Aug 20 '15 at 6:02
1

This is a prevailing bug/conflict/issue with windows phone. I have experienced it a lot and resetting my router works most of the times. Second option would be restarting your handset. If either of the steps fails to connect, try changing WEP to WPA and vice versa in your router settings. If it is still unresolved, manually assign an IP address to your handset. Settings -> Wi-Fi -> static-ip.

0

Is your router encryption set to WEP by any change? If so, try setting it to WPA and see if your phone connects or try rebooting your router and see if that helps.

0

Try these, you can go to Settings > WiFi > WiFi sense , then turn off Connect to suggested open hotspots and Connect to networks shared by my contacts.

  • Please add an explanation as to how this would fix it. – RareNCool Oct 19 '15 at 20:37
0

If you are using windows phone 8.1 Os than static IP might be the possible issue: Read detailed solution here or else you can watch this video

As I stated The reason might be Static IP, which is a new feature introduced in the LUMIA CYAN update with windows phone 8.1.

So you will have to turn off static IP, possibly if the settings does not match the particular default gateway your are trying to connect.

You can find the detailed description in the links given. The blog has some more reasons mentioned in the article, but mainly this is the major issues concerned with the phone, other reasons are related to router and internet.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.